Bug 1579288 - fail to upgrade against system conatiner ocp when backup etcd due to etcd command was wrongly set to etcdctl
Summary: fail to upgrade against system conatiner ocp when backup etcd due to etcd com...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Cluster Version Operator
Version: 3.10.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 3.10.0
Assignee: Vadim Rutkovsky
QA Contact: liujia
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-17 10:05 UTC by liujia
Modified: 2018-07-30 19:16 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-07-30 19:15:42 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:1816 None None None 2018-07-30 19:16:03 UTC

Description liujia 2018-05-17 10:05:14 UTC
Description of problem:
Fail to upgrade against system container ocp at task [etcd : Generate etcd backup] due to etcd command was wrongly set to etcdctl.
TASK [etcd : Generate etcd backup] *********************************************
task path: /usr/share/ansible/openshift-ansible/roles/etcd/tasks/backup/backup.yml:52
Thursday 17 May 2018  09:40:29 +0000 (0:00:01.676)       0:35:18.872 ********** 
fatal: [1]: FAILED! => {"changed": false, "cmd": "etcdctl backup --data-dir=/var/lib/etcd/ --backup-dir=/var/lib/etcd//openshift-backup-pre-upgrade-20180517094021", "failed": true, "msg": "[Errno 2] No such file or directory", "rc": 2}
fatal: [2]: FAILED! => {"changed": false, "cmd": "etcdctl backup --data-dir=/var/lib/etcd/ --backup-dir=/var/lib/etcd//openshift-backup-pre-upgrade-20180517094021", "failed": true, "msg": "[Errno 2] No such file or directory", "rc": 2}
fatal: [3]: FAILED! => {"changed": false, "cmd": "etcdctl backup --data-dir=/var/lib/etcd/ --backup-dir=/var/lib/etcd//openshift-backup-pre-upgrade-20180517094021", "failed": true, "msg": "[Errno 2] No such file or directory", "rc": 2}

[root@ip-172-18-6-252 ~]# etcdctl backup --data-dir=/var/lib/etcd/ --backup-dir=/var/lib/etcd//openshift-backup-pre-upgrade-20180517094021
bash: etcdctl: command not found
[root@ip-172-18-6-252 ~]# runc list|grep etcd
etcd                                  7486        running     /var/lib/containers/atomic/etcd.0                                  2018-05-17T07:52:13.08897428Z    root
[root@ip-172-18-6-252 ~]# rpm -qa|grep etcd
[root@ip-172-18-6-252 ~]# 


Version-Release number of the following components:
ansible-2.4.4.0-1.el7ae.noarch
openshift-ansible-3.10.0-0.47.0.git.0.c018c8f.el7.noarch

How reproducible:
always

Steps to Reproduce:
1. system container install ocp on rhel
openshift_use_system_containers: true
system_images_registry: 'registry.reg-aws.openshift.com:443'
2. upgrade above ocp
3.

Actual results:
Upgrade failed.

Expected results:
Upgrade succeed.

Additional info:
Please attach logs from ansible-playbook with the -vvv flag

Comment 2 liujia 2018-05-21 02:21:01 UTC
Blocked system container upgrade.

Comment 3 Vadim Rutkovsky 2018-05-21 14:57:55 UTC
Can't reproduce on openshift-ansible-3.10.0-0.48.0 with Origin and 

openshift_use_system_containers=true
containerized=true

Could this be repeated on new install?

Comment 8 Vadim Rutkovsky 2018-05-22 11:40:02 UTC
Created https://github.com/openshift/openshift-ansible/pull/8471

Comment 9 Vadim Rutkovsky 2018-05-24 07:40:02 UTC
Fix is available in openshift-ansible-3.10.0-0.51.0

Comment 10 liujia 2018-05-29 09:47:03 UTC
Verified on openshift-ansible-3.10.0-0.53.0.git.0.53fe016.el7.noarch for both 2.1 and 2.2 deployment.

Comment 12 errata-xmlrpc 2018-07-30 19:15:42 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:1816


Note You need to log in before you can comment on or make changes to this bug.