Bug 1579434 - openshift-ansible docker image missing requirements
Summary: openshift-ansible docker image missing requirements
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 3.10.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 3.10.0
Assignee: Scott Dodson
QA Contact: Peter Ruan
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-17 16:02 UTC by Peter Ruan
Modified: 2019-04-14 09:09 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
undefined
Clone Of:
Environment:
Last Closed: 2018-07-30 19:16:09 UTC
Target Upstream Version:
jmalde: needinfo-


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:1816 None None None 2018-07-30 19:16:29 UTC

Description Peter Ruan 2018-05-17 16:02:41 UTC
Description of problem:
  We need to add a package into the origin/ansible docker image.  For 3.10 it needs patch package, currently QE is using that base image to spin up and run ansible-playbook but all of our automation failed due to the lack of patch package within the official image.  According to the official doc, the following requirements are needed to install the various services.
 
Additional requirements:
Logging:
    •    java-1.8.0-openjdk-headless
    •    patch
Metrics:
    •    httpd-tools 


Version-Release number of the following components:

ansible 2.5.2

How reproducible:
always.

Steps to Reproduce:
1. ansible-playbook -i /tmp/tmp/install_inventory -vv /usr/share/ansible/openshift-ansible/playbooks/openshift-logging/config.yml
2.
3.

Actual results:
TASK [openshift_logging : command] ******************************************************************************************
task path: /usr/share/ansible/openshift-ansible/roles/openshift_logging/tasks/patch_configmap_file.yaml:45
Thursday 17 May 2018  06:16:49 +0000 (0:00:00.599)       0:02:48.957 **********
fatal: [ec2-204-236-242-114.compute-1.amazonaws.com -> localhost]: FAILED! => {"changed": false, "cmd": "patch --force --quiet -u /tmp/openshift-logging-ansible-mzDgtM/configmap_new_file /tmp/openshift-logging-ansible-mzDgtM/patch.patch", "msg": "[Errno 2] No such file or directory", "rc": 2}
 
PLAY RECAP ******************************************************************************************************************
ec2-204-236-242-114.compute-1.amazonaws.com : ok=156  changed=16   unreachable=0    failed=1
localhost                  : ok=11   changed=0    unreachable=0    failed=0
 
 
Expected results:

Additional info:
Please attach logs from ansible-playbook with the -vvv flag

Comment 2 Scott Dodson 2018-05-21 13:50:56 UTC
In openshift-ansible-3.10.0-0.48.0

Comment 3 Scott Dodson 2018-05-25 12:43:25 UTC
Peter can you verify this is fixed?

Comment 4 Peter Ruan 2018-06-05 06:01:31 UTC
verified with the latest ose/ansible docker image

sh-4.2$ ansible-playbook --version
ansible-playbook 2.5.3
  config file = /usr/share/ansible/openshift-ansible/ansible.cfg
  configured module search path = [u'/opt/app-root/src/.ansible/plugins/modules', u'/usr/share/ansible/plugins/modules']
  ansible python module location = /usr/lib/python2.7/site-packages/ansible
  executable location = /usr/bin/ansible-playbook
  python version = 2.7.5 (default, Aug  4 2017, 00:39:18) [GCC 4.8.5 20150623 (Red Hat 4.8.5-16)]
sh-4.2$ ansible --version
ansible 2.5.3
  config file = /usr/share/ansible/openshift-ansible/ansible.cfg
  configured module search path = [u'/opt/app-root/src/.ansible/plugins/modules', u'/usr/share/ansible/plugins/modules']
  ansible python module location = /usr/lib/python2.7/site-packages/ansible
  executable location = /usr/bin/ansible
  python version = 2.7.5 (default, Aug  4 2017, 00:39:18) [GCC 4.8.5 20150623 (Red Hat 4.8.5-16)]
sh-4.2$ patch --version
GNU patch 2.7.1

Comment 11 errata-xmlrpc 2018-07-30 19:16:09 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:1816


Note You need to log in before you can comment on or make changes to this bug.