Bug 157952 - httpd piped logging fd leak, graceful restart handling
httpd piped logging fd leak, graceful restart handling
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: httpd (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Joe Orton
:
Depends On:
Blocks: 156322
  Show dependency treegraph
 
Reported: 2005-05-17 08:46 EDT by Joe Orton
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version: RHBA-2005-622
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-05 11:38:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joe Orton 2005-05-17 08:46:14 EDT
Two piped logging bugs filed against RHEL3 (bug 157832, bug 127981) also affect
httpd in RHEL4:

1. there is an fd leak when spawning piped loggers, which can eventually use up
all fds e.g. prevent new piped loggers from starting, etc.  (bug 157832)

2. the "read" end of the pipe created to a piped logger is not closed.  During a
graceful restart, after the httpd parent kills a piped logger helper, the pipe
is never closed since each child has both ends of the pipe open.  When a
lingering child writes log entries to the pipe, it will then hang once the pipe
buffer fills up, since nobody is reading from the other end.  (bug 127981)
Comment 5 Red Hat Bugzilla 2005-10-05 11:38:00 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2005-622.html

Note You need to log in before you can comment on or make changes to this bug.