Bug 1579598 - Public hostname provided by `oc cluster up --public-hostname` redirects to https://127.0.0.1:8443 and failed to be accessed
Summary: Public hostname provided by `oc cluster up --public-hostname` redirects to ht...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: oc
Version: 3.10.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 3.10.0
Assignee: Juan Vallejo
QA Contact: Xingxing Xia
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-18 02:07 UTC by Xingxing Xia
Modified: 2019-06-07 21:48 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-07-30 19:16:09 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:1816 None None None 2018-07-30 19:16:29 UTC

Description Xingxing Xia 2018-05-18 02:07:38 UTC
Description of problem:
Public hostname provided by `oc cluster up --public-hostname` redirects to https://127.0.0.1:8443 and failed to be accessed
Checked webconsole-config configmap, it uses https://127.0.0.1:8443

Version-Release number of selected component (if applicable):
$ oc version
oc v3.10.0-0.47.0
...
Server https://10.8...:8443
openshift v3.10.0-0.47.0
...

How reproducible:
Always

Steps to Reproduce:
1. In remote host, run:
oc cluster up --public-hostname=10.8... --image='brew-.../openshift3/ose-${component}:${version}' # single quotes
...
OpenShift server started.

The server is accessible via web console at:
    https://10.8...:8443

You are logged in as:
    User:     developer
    Password: <any value>

To login as administrator:
    oc login -u system:admin

2. In local browser, visit https://10.8...:8443, it goes to https://127.0.0.1:8443

3. Check config:
$ oc login -u system:admin
$ oc get cm webconsole-config -n openshift-web-console -o yaml
... "consolePublicURL":"https://127.0.0.1:8443/console/","masterPublicURL":"https://127.0.0.1:8443" ...


Actual results:
2. Cannot visit https://10.8...:8443
3. It uses 127.0.0.1.
If manually change consolePublicURL to use 10.8..., the browser can visit login page, but the login always redirects to login page.
If manually change masterPublicURL to use 10.8... as well, browser can visit and login to web console

Expected results:
Can visit https://10.8...:8443 successfully

Additional info:
cd openshift.local.clusterup/
grep masterPublicURL `find . -name "master-config.yaml"` # the master-config.yaml is good 'masterPublicURL: https://10.8...:8443'

Comment 1 Michal Fojtik 2018-05-21 09:22:21 UTC
Should be fixed in https://github.com/openshift/origin/pull/19741

Comment 2 Xingxing Xia 2018-05-22 01:47:52 UTC
Verified in oc v3.10.0-0.50.0. Now configmap uses public host name and that url can be accessed. Thx

Comment 4 errata-xmlrpc 2018-07-30 19:16:09 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:1816


Note You need to log in before you can comment on or make changes to this bug.