Bug 1579723 - Install ASB failed when enable the "ansible_service_broker_enable_dashboard_redirector"
Summary: Install ASB failed when enable the "ansible_service_broker_enable_dashboard_r...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Service Broker
Version: 3.10.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 3.10.0
Assignee: Dylan Murray
QA Contact: Jian Zhang
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-18 08:05 UTC by Jian Zhang
Modified: 2018-07-30 19:16 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
undefined
Clone Of:
Environment:
Last Closed: 2018-07-30 19:16:09 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:1816 None None None 2018-07-30 19:16:29 UTC

Description Jian Zhang 2018-05-18 08:05:38 UTC
Description of problem:
Install the ASB failed when enable the "ansible_service_broker_enable_dashboard_redirector". Errors as below:

TASK [ansible_service_broker : Create config map for ansible-service-broker] ***
Thursday 17 May 2018  09:58:11 +0000 (0:00:00.024)       0:04:28.769 ********** 
fatal: [ec2-34-204-75-159.compute-1.amazonaws.com]: FAILED! => {"failed": true, "msg": "The task includes an option with an undefined variable. The error was: 'ansible_service_broker_dashboard_redirector' is undefined\n\nThe error appears to have been in '/usr/share/ansible/openshift-ansible/roles/ansible_service_broker/tasks/install.yml': line 196, column 3, but may\nbe elsewhere in the file depending on the exact syntax problem.\n\nThe offending line appears to be:\n\n# TODO: saw a oc_configmap in the library, but didn't understand how to get it to do the following:\n- name: Create config map for ansible-service-broker\n  ^ here\n\nexception type: <class 'ansible.errors.AnsibleUndefinedVariable'>\nexception: 'ansible_service_broker_dashboard_redirector' is undefined"}

Version-Release number of selected component (if applicable):
openshift-ansible-3.10.0-0.47.0


How reproducible:
always

Steps to Reproduce:
1. Config the "ansible_service_broker_enable_dashboard_redirector=true" in the inventory file before install the ASB.
2. Install the ASB by running the playbooks.

Actual results:
Got errors:
TASK [ansible_service_broker : Create config map for ansible-service-broker] ***
Thursday 17 May 2018  09:58:11 +0000 (0:00:00.024)       0:04:28.769 ********** 
fatal: [ec2-34-204-75-159.compute-1.amazonaws.com]: FAILED! => {"failed": true, "msg": "The task includes an option with an undefined variable. The error was: 'ansible_service_broker_dashboard_redirector' is undefined\n\nThe error appears to have been in '/usr/share/ansible/openshift-ansible/roles/ansible_service_broker/tasks/install.yml': line 196, column 3, but may\nbe elsewhere in the file depending on the exact syntax problem.\n\nThe offending line appears to be:\n\n# TODO: saw a oc_configmap in the library, but didn't understand how to get it to do the following:\n- name: Create config map for ansible-service-broker\n  ^ here\n\nexception type: <class 'ansible.errors.AnsibleUndefinedVariable'>\nexception: 'ansible_service_broker_dashboard_redirector' is undefined"}

Expected results:
Install the ASB successfully.

Additional info:

Comment 1 Jian Zhang 2018-05-18 08:14:19 UTC
I submit a PR(https://github.com/openshift/openshift-ansible/pull/8426) to fix this issue, looking forward to your comments.

Comment 2 Dylan Murray 2018-05-18 11:26:12 UTC
Thanks Jian, the changes you made look good!

Moving the bug to POST.

Comment 3 openshift-github-bot 2018-05-18 12:33:50 UTC
Commits pushed to master at https://github.com/openshift/openshift-ansible

https://github.com/openshift/openshift-ansible/commit/80dfcfe05247563997bd8f46bb0d61fae784a213
bug 1579723: use ansible_service_broker_dashboard_redirector_route in ASB configmap

https://github.com/openshift/openshift-ansible/commit/8903a3319e1c1574df902075019ac3c2dac77e62
Merge pull request #8426 from jianzhangbjz/asb

fix bug 1579723

Comment 4 Jian Zhang 2018-05-31 05:16:36 UTC
Change status to "ON_QA" since the fixed PR has merged into openshift-ansible-3.10.0-0.54.0 version.

Comment 5 Jian Zhang 2018-05-31 05:17:22 UTC
Verify it.

Enable it in inventory file:
...
ansible_service_broker_enable_dashboard_redirector=true
ansible_service_broker_install=true

#ansible-playbook -i qe-inventory-host-file playbooks/openshift-service-catalog/config.yml

Installation works well.
[root@qe-jiazha-31master-etcd-1 ~]# oc get route
NAME       HOST/PORT                                                                PATH      SERVICES   PORT      TERMINATION   WILDCARD
asb-1338   asb-1338-openshift-ansible-service-broker.apps.0530-ngj.qe.rhcloud.com             asb        1338      reencrypt     None
dr-1337    dr-1337-openshift-ansible-service-broker.apps.0530-ngj.qe.rhcloud.com              asb        1337                    None
[root@qe-jiazha-31master-etcd-1 ~]# oc get pods
NAME          READY     STATUS    RESTARTS   AGE
asb-1-24tjs   2/2       Running   0          53s

Comment 7 errata-xmlrpc 2018-07-30 19:16:09 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:1816


Note You need to log in before you can comment on or make changes to this bug.