Bug 1579736 - Additional log messages in dht_readdir(p)_cbk
Summary: Additional log messages in dht_readdir(p)_cbk
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: distribute
Version: 4.1
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Nithya Balachandran
QA Contact:
URL:
Whiteboard:
Depends On: 1575887
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-18 08:31 UTC by Nithya Balachandran
Modified: 2018-06-20 18:06 UTC (History)
1 user (show)

Fixed In Version: glusterfs-v4.1.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1575887
Environment:
Last Closed: 2018-06-20 18:06:39 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Nithya Balachandran 2018-05-18 08:31:43 UTC
+++ This bug was initially created as a clone of Bug #1575887 +++

Description of problem:

We have seen issues recently where files/directories do not show up on the mountpoint though they exist on the bricks. As DHT filters out entries returned by the bricks, it is useful to know what entries have reached DHT and which ones have been filtered out in order to debug such issues.

Adding debug messages to dht_readdir(p)_cbk will allow us to see this at the DHT layer.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

--- Additional comment from Worker Ant on 2018-05-08 04:29:49 EDT ---

REVIEW: https://review.gluster.org/19980 (cluster/dht: Debug logs in dht_readdir(p)_cbk) posted (#1) for review on master by N Balachandran

--- Additional comment from Worker Ant on 2018-05-08 23:45:58 EDT ---

COMMIT: https://review.gluster.org/19980 committed in master by "Raghavendra G" <rgowdapp@redhat.com> with a commit message- cluster/dht: Debug logs in dht_readdir(p)_cbk

Additional log messages to help debug issues
with file listings.

Change-Id: Iccd07498ba01d597c0c40f026f4177dd06d7e901
fixes: bz#1575887
Signed-off-by: N Balachandran <nbalacha@redhat.com>

Comment 1 Worker Ant 2018-05-18 08:34:06 UTC
REVIEW: https://review.gluster.org/20034 (cluster/dht: Debug logs in dht_readdir(p)_cbk) posted (#1) for review on release-4.1 by N Balachandran

Comment 2 Worker Ant 2018-05-22 10:27:30 UTC
COMMIT: https://review.gluster.org/20034 committed in release-4.1 by "Shyamsundar Ranganathan" <srangana@redhat.com> with a commit message- cluster/dht: Debug logs in dht_readdir(p)_cbk

Additional log messages to help debug issues
with file listings.

(cherry picked from commit d3e3b11d38b927cf849d2d7a20460650963fd438)
Change-Id: Iccd07498ba01d597c0c40f026f4177dd06d7e901
fixes: bz#1579736
Signed-off-by: N Balachandran <nbalacha@redhat.com>

Comment 3 Shyamsundar 2018-06-20 18:06:39 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-v4.1.0, please open a new bug report.

glusterfs-v4.1.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/announce/2018-June/000102.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.