Bug 1579769 - inode status command is broken with distributed replicated volumes
Summary: inode status command is broken with distributed replicated volumes
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: core
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: hari gowtham
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1559452
TreeView+ depends on / blocked
 
Reported: 2018-05-18 09:55 UTC by hari gowtham
Modified: 2018-10-23 15:09 UTC (History)
2 users (show)

Fixed In Version: glusterfs-5.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-10-23 15:09:12 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description hari gowtham 2018-05-18 09:55:28 UTC
Description of problem:
The brick op of inode status commands fails on a distributed volumes as it fails to acquire lock.


Version-Release number of selected component (if applicable):
3.12.2-8

How reproducible:
100

Steps to Reproduce:
1. create a distributed replicated volume.
2. mount it and create a lot of files.
3. issue gluster volume status volname inodes 

Actual results:
Commit fails on the remote nodes.

Expected results:
should print the inodes status output with the connections. without the commit failing (prints it as commit failed but its a brickop failure.)

Additional info:

Comment 1 Worker Ant 2018-05-18 09:57:26 UTC
REVIEW: https://review.gluster.org/20035 (Core: The lock contention on gf_client_dump_inodes_to_dict) posted (#1) for review on master by hari gowtham

Comment 2 Worker Ant 2018-05-30 03:37:40 UTC
COMMIT: https://review.gluster.org/20035 committed in master by "Amar Tumballi" <amarts@redhat.com> with a commit message- Core: The lock contention on gf_client_dump_inodes_to_dict

Problem: For a distributed replicated volume, in the inode status
command the lock on gf_client_dump_inodes_to_dict is held by the
first brickop. while this is being processed, if the second brickop
comes. It fails to get the lock and the whole brick op fails.

Fix: Instead of using a TRY_LOCK which errors out if the lock is busy,
Use LOCK which will wait till the lock is acquired.

Change-Id: I768a0a1b60f28c4f7f94549e18ee3765b69cc528
fixes: bz#1579769
Signed-off-by: hari gowtham <hgowtham@redhat.com>

Comment 3 Shyamsundar 2018-10-23 15:09:12 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-5.0, please open a new bug report.

glusterfs-5.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://lists.gluster.org/pipermail/announce/2018-October/000115.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.