Bug 158017 - Partition table damaged after install
Partition table damaged after install
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: parted (Show other bugs)
4
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Chris Lumens
Brock Organ
:
: 158018 158019 158020 158028 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-05-17 16:41 EDT by dj
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-23 10:58:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
lost form data in XML. (2.80 KB, text/plain)
2005-05-19 04:02 EDT, dj
no flags Details

  None (edit)
Description Miloslav Trmač 2005-05-17 16:53:57 EDT
*** Bug 158018 has been marked as a duplicate of this bug. ***
Comment 1 Miloslav Trmač 2005-05-17 16:54:07 EDT
*** Bug 158019 has been marked as a duplicate of this bug. ***
Comment 2 Miloslav Trmač 2005-05-17 16:54:24 EDT
*** Bug 158020 has been marked as a duplicate of this bug. ***
Comment 3 dj 2005-05-17 18:09:42 EDT
*** Bug 158028 has been marked as a duplicate of this bug. ***
Comment 4 Jeremy Katz 2005-05-18 21:12:08 EDT
Do you have any more details to provide on how the partition table was damaged?
Comment 5 dj 2005-05-19 04:01:21 EDT
Yes, of course. I'm sorry. I got an "internal server error" from bugzilla,
mailed the info to the mail address in the error message and hoped they would
fix it.
Anyway, please see the attached file. It contains an XML-ized version of the
HTML form.
Comment 6 dj 2005-05-19 04:02:39 EDT
Created attachment 114557 [details]
lost form data in XML.
Comment 7 Chris Lumens 2005-05-26 11:05:29 EDT
Your initial report indicates you got a failed assertion error message.  Could
you please post the text of that error message?
Comment 8 Jeremy Brown 2005-05-26 12:31:38 EDT
Not sure if this is the same bug, but after installing FC4T3 on my work laptop
(A Thinkpad T42) the partition table was incorrect.  I generally dual boot, but
Windows was unable to boot up without showing me a blue screen.  I stuck in a
rescue disc and attempted to use cfdisk, which reported that the hard disk
partition table was invalid (I think it said that the FC4T3 partition extended
past the end of the hard disk).

I was finally able to boot up pure fdisk, delete the FC4 partitions, and then
re-write the partition table.  After following this with an MBR wipe, I was able
to boot into Windows again, and cfdisk reported everything was OK as well.

(Sorry I don't have a more detailed record of what happened.  I would attempt to
reproduce, but I can't afford to risk hosing my work machine again, and I don't
have any free test boxes sitting around)
Comment 9 dj 2005-05-27 04:16:50 EDT
I did an extra bug report for the error message: bug 158156.

Copied & pasted from there:

The message is: "Assertion (metadata_length > 0) at disk_dos.c: 1942 in function
add_logical_part_metadata() failed."
On the console there is also "96" printed on the next line after those messages.
Comment 10 Chris Lumens 2005-06-09 15:07:10 EDT
Did you run into this problem only after seeing the assertion failure?  What
steps did you take after seeing the message - ignore or cancel?
Comment 11 Chris Lumens 2005-09-23 10:58:49 EDT
Since there are insufficient details provided in this report for us to
investigate the issue further, and we have not received the feedback we
requested, we will assume the problem was not reproduceable or has been fixed in
a later update for this product.  If you have further details, feel free to
reopen the report with the additional details attached.

Note You need to log in before you can comment on or make changes to this bug.