Bug 158032 - Greek fonts available under a free licence
Greek fonts available under a free licence
Status: CLOSED DUPLICATE of bug 170218
Product: Fedora
Classification: Fedora
Component: distribution (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Bill Nottingham
: FutureFeature
: 74364 (view as bug list)
Depends On:
Blocks: FC5Target
  Show dependency treegraph
 
Reported: 2005-05-17 19:08 EDT by Nikos Charonitakis
Modified: 2014-03-16 22:53 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-28 12:02:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
mgopen-fonts spec file (1.88 KB, text/plain)
2005-06-21 04:43 EDT, Sarantis Paskalis
no flags Details

  None (edit)
Description Nikos Charonitakis 2005-05-17 19:08:38 EDT
Description of problem:
(i dont know the right component for this so i select fonts-xorg)

Redhat Linux 7.2 was the last (i think) Redhat product that included Greek fonts
Now there is a chance to get Greek fonts back to fedora core.
A Greek fonts company called Magenta created fonts with free licence (bitestream
vera like licence).
The fonts are: MgOpenCanonica,  MgOpenCosmetica,  MgOpenModata,  MgOpenModerna.
For more information follow this link
http://www.ellak.gr/fonts/mgopen/index.en 

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. fedora/redhat distibution does not include Greek fonts
2.
3.
  
Actual results:Users have to install themselves Greek fonts that usually are
under restricted licences (mscorefonts for example)
 

Expected results:Fedora/redhat to include with Greek fonts by default


Additional info:
Comment 1 Mike A. Harris 2005-05-20 19:47:35 EDT
Hi, thanks for the request.

For future reference, requests of this nature should be filed against the
"distribution" component, as they're general feature requests for the OS
distribution, rather than specific to X.Org X11 itself.

Hope this helps...

Reassigning to distribution component, and CC'ing Owen.



(The "fonts-xorg" package is exclusively fonts provided by the X.Org
foundation, extracted from X.Org X11 and repackaged as "fonts-xorg"
to be able to separate font generation from the rest of the monolithic
tree, and to be able to provide the Xorg fonts as "noarch" packages.
Fonts only get added to X.Org, when they are added to the upstream
X.Org project directly.)

Comment 3 Bill Nottingham 2005-05-20 20:48:54 EDT
Generally, to add fonts, we need to answer the following, taken from
Owen Taylor's post at:
https://listman.redhat.com/archives/rhl-devel-list/2003-August/msg00154.html

 * What set of fonts should be included, each font really should
   be justified as serving a different purpose.

   What I mean by a purpose is:

    - This font looks good on the screen
    - This font exhibits the <X> style of <language> script,
      people expect to have fonts with both the <X> and 
      <Y> styles of scripts available.

   Or whatever.
 
 * For each font, a summary of:
   
   - What is the license of the fonts?
   - Who drew the glyphs? If the font contains Roman characters
     as well, where did they come from?
   - Where did the design of the glyphs come from? (In some countries,
     font designs are patentable or otherwise protected, so a 
     exact copy of an existing commerical font is not a good idea.)
   - Where did the name come from? (Font names are trademarkable)
   
 * Some indication of how useful the bugs are with the software
   we ship currently. Screenshots of what works, and what doesn't
   might be useful.
Comment 4 Simos Xenitellis 2005-05-21 20:46:33 EDT
(In reply to comment #3)
> Generally, to add fonts, we need to answer the following, taken from
> Owen Taylor's post at:
> https://listman.redhat.com/archives/rhl-devel-list/2003-August/msg00154.html
> 
>  * What set of fonts should be included, each font really should
>    be justified as serving a different purpose.
> 
>    What I mean by a purpose is:
> 
>     - This font looks good on the screen
>     - This font exhibits the <X> style of <language> script,
>       people expect to have fonts with both the <X> and 
>       <Y> styles of scripts available.
> 
>    Or whatever.
>  
>  * For each font, a summary of:
>    
>    - What is the license of the fonts?

Same license as with Bitstream Vera (http://www.gnome.org/fonts/).
The fonts have been included already in Debian, so the licensing has been
verified to be ok (well, it's Bitstream Vera-style!). See:
http://packages.debian.org/testing/x11/ttf-mgopen

See http://www.ellak.gr/fonts/mgopen/ for the actual text of the licence.

>    - Who drew the glyphs? If the font contains Roman characters
>      as well, where did they come from?

There are Roman characters in all four font families.
The fonts came from Magenta Ltd (http://www.magenta.gr), a well-known Greek
software house.

>    - Where did the design of the glyphs come from? (In some countries,
>      font designs are patentable or otherwise protected, so a 
>      exact copy of an existing commerical font is not a good idea.)
>    - Where did the name come from? (Font names are trademarkable)

I am not sure if you followed the GNOME Foundation process to open-source
Bitstream Vera. The font family used to be called Bitstream Prima and when it
was open-source, the name changed to Bitstream Vera (Prima+Vera=Primavera or
"spring" in Spanish, nice :). Therefore, there is no clash with the product of
the company (Bitstream).

In this case, the fonts already have their own name as they were sold by
Magenta.gr. So, each font's name is made up of
"MgOpen" (denotes Mg: Magenta, Open: OpenSource) and a new Greek word.
So we have:

MgOpen Canonica
MgOpen Cosmetica
MgOpen Modata
MgOpen Moderna

To the best of my knowledge and of other knowledgable people, these names are
not taken. In fact, it's not common at all to use Greek names for font names, so
I strongly doubt there is a clash. 

>  * Some indication of how useful the bugs are with the software
>    we ship currently. Screenshots of what works, and what doesn't
>    might be useful.

All four font families support modern Greek (Greek Unicode range), and one of
them (Canonica) supports Ancient Greek (Greek Extended Unicode range).

As Nikos mentions, there is a sad lack of Greek fonts in Fedora Core.

Some demos:
1. http://www.ellak.gr/fonts/mgopen/
2. http://planet.hellug.gr/misc/mgopen-demo.pdf
3. http://planet.hellug.gr/misc/mgopen-demo.odt (same as above, in OOo 2.0 format)
4. http://www.livejournal.com/users/simos74/41698.html (in Greek)
5. http://www.livejournal.com/users/simos74/40486.html (The Greek GNOME LiveCD
boot screen uses MgOpen Modata and MgOpen Canonica.
Comment 6 Zenon Mousmoulas 2005-05-22 08:58:44 EDT
(In reply to comment #3)

Hi Nikos, Bill, Simos et al.

Bill, your questions have been mostly covered by the previous answers, so let me
just add some further clarifications.

> Generally, to add fonts, we need to answer the following, taken from
> Owen Taylor's post at:
> https://listman.redhat.com/archives/rhl-devel-list/2003-August/msg00154.html
> 
>  * What set of fonts should be included, each font really should
>    be justified as serving a different purpose.
> 
>    What I mean by a purpose is:
> 
>     - This font looks good on the screen
>     - This font exhibits the <X> style of <language> script,
>       people expect to have fonts with both the <X> and 
>       <Y> styles of scripts available.

I'm not really sure what the answer should be to this question, however if you
look at http://www.ellak.gr/fonts/mgopen/ you will find bitmap samples of the
fonts and a short description of their style. I'm not sure I understand the
second topic regarding scripts, however as the previous reporters posted, all
four fonts feature glyphs for the representation of modern Greek.

>  * For each font, a summary of:
>    
>    - What is the license of the fonts?
>    - Who drew the glyphs? If the font contains Roman characters
>      as well, where did they come from?
>    - Where did the design of the glyphs come from? (In some countries,
>      font designs are patentable or otherwise protected, so a 
>      exact copy of an existing commerical font is not a good idea.)
>    - Where did the name come from? (Font names are trademarkable)

All fonts are covered by the same license, which has been closely modeled after
the one used for Bitstream Vera. The essence of this license is that everyone is
free to use, change and redistribute the fonts as long as: the fonts aren't sold
individually and by themselves, and that if changes are made the fonts are no
longer distributed under the same name.
These fonts were designed by Magenta Ltd, the software house who is also the
copyright holder of MgOpen. Their design came from existing and previously
commercially available fonts that were selected among the company's large
portfolio specifically for this purpose, at the company's will, so as to be
released as MgOpen. Therefore no unconscious verbatim copying has taken place.
Also to be noted, no copyright infringement claims (or even suspicion thereof)
have ever surfaced regarding these fonts or their "predecessors".
Despite the fact that fonts commonly share names which characterize and
categorize them according to design (such as Times or Helvetica), the adopted
font names are first of all original and have been checked against existing
trademarks by a legal counsel and, in accordance to the provisions of the law,
have found to be free of any such claims and perfectly suitable for use. 

I hope this helps.
Comment 7 Sarantis Paskalis 2005-06-17 05:06:53 EDT
FWIW, I have created some rpms based on the bitstream vera rpms at
http://gallagher.di.uoa.gr/any/rpms/
Comment 8 Rahul Sundaram 2005-06-20 15:15:10 EDT
Sarantis Paskalis,

Couldnt access the website. Would you mind submitting the spec files rather than
the RPMS
Comment 9 Sarantis Paskalis 2005-06-21 04:43:01 EDT
Created attachment 115737 [details]
mgopen-fonts spec file
Comment 10 Sarantis Paskalis 2005-06-21 04:47:46 EDT
Sorry about the downtime of the site.  The machine had its power unit failed.

The site is back up and contains the last version of the [S,]RPMS.  For naming
and  versioning please see also the discussion for this package in fedora-extras
list starting at
http://www.redhat.com/archives/fedora-extras-list/2005-June/msg00483.html

RPM: http://gallagher.di.uoa.gr/any/rpms/mgopen-fonts-0.20050515-1.noarch.rpm
SRPM: http://gallagher.di.uoa.gr/any/rpms/mgopen-fonts-0.20050515-1.src.rpm


Thanks
Comment 11 Sarantis Paskalis 2005-07-10 11:38:34 EDT
mgopen-fonts is now available for Fedora Extras (FC-3, FC-4 and development).
Comment 12 Rahul Sundaram 2005-08-12 19:51:03 EDT

Since these fonts are now available in Fedora Extras repository, I am closing
this bug report. If you have any further questions on this kindly report a new
bug. Thank you
Comment 13 Rahul Sundaram 2005-08-12 20:03:13 EDT

Should this be added to Fedora core itself?
Comment 14 Sarantis Paskalis 2005-08-14 02:32:36 EDT
All the other non-latin fonts are in Core (fonts-bengali, fonts-gujarati,
fonts-hindi, fonts-punjabi, fonts-tamil, fonts-chinese, fonts-korean,
fonts-japanese, fonts-arabic, fonts-hebrew, and some others for x.org).

In Extras the fonts-specific packages are dejavu-fonts (a derivative of
bitstream-vera with more glyphs covered), mathml-fonts and some TeX specific fonts.

I would say to keep all the non-core fonts in one place (Core or Extras).  If a
decision is made to trim the Core packages to 1 or 2 CDs, then all the font
packages should be transfered to Extras.  If not, then mgopen-fonts should be
included in core (possibly renamed to fonts-greek for homogeneity reasons).
Comment 15 Rahul Sundaram 2005-09-04 22:26:59 EDT
Ok. It makes sense to maintain status quo till we reach a decision on trimming
down packages on FC
Comment 16 Nicolas Mailhot 2006-01-16 02:20:59 EST
btw dejavu is supposed to have a complete greek fontset now (2.2)
would be nice is some greek users compared it to mgopen
Comment 17 Nikos Charonitakis 2006-02-11 05:19:47 EST
(In reply to comment #16)
> btw dejavu is supposed to have a complete greek fontset now (2.2)
> would be nice is some greek users compared it to mgopen

i m dont have knowledge to make a valid comparison between mgopen and dejavu.
having said that. I tried dejavu and they are looking nicer, also they support
monospace fonts and euro symbol (mgopen not yet).

Comment 18 Simos Xenitellis 2006-02-24 18:12:22 EST
I just tried Fedora Core 5 test 3. Indeed, the default Greek fonts are of very
bad quality.

If I were to decide which between MgOpen and DejaVu to use, my personal
preference would be Dejavu (version 2.3).

DejaVu 2.3 has a complete fontset for modern greek on the full set of Sans,
Serif and Sans Mono.

DejaVu provides support for latin, greek and cyrillic, including their extended
groups, meaning that the coverage is quite good.

I would recommend to include DejaVu 2.3 as a default sans/serif/monospace font
and also configure /etc/fonts.conf so that it appears high on the list (perhaps
just under BitStream Vera, as Ubuntu Dapper has).
Comment 19 Nikos Charonitakis 2006-02-27 18:26:33 EST
i vote for dejavu too. They are really nice (i use the latest version for FC4
from extras).
It 's time fedora to get Greek fonts back in distribution after so many years...
Comment 20 Sarantis Paskalis 2006-02-28 03:33:49 EST
RFE for including dejavu in Core and making it the default font is in bug #170218.
(FWIW, I also strongly support it).
Comment 21 Simos Xenitellis 2006-02-28 07:25:32 EST
Link to screenshot with FC 5 (test3), Greek and DejaVu 2.3,
http://static.flickr.com/39/104237661_b907d87820_o.png
It has never been as good as this with free fonts.

(this requires 
a. installation of DejaVu 2.3 by default and 
b. editing /etc/fonts/fonts.conf so that DejaVu is after Vera in the preference
list)
Comment 22 Bill Nottingham 2006-02-28 12:02:30 EST
Closing as a dup of 170218.

*** This bug has been marked as a duplicate of 170218 ***
Comment 23 John Thacker 2006-04-21 20:38:51 EDT
*** Bug 74364 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.