Bug 1580532 - posix/ctime: The first lookup on file is not healing the gfid
Summary: posix/ctime: The first lookup on file is not healing the gfid
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: posix
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kotresh HR
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1582080
TreeView+ depends on / blocked
 
Reported: 2018-05-21 17:29 UTC by Kotresh HR
Modified: 2018-10-23 15:09 UTC (History)
1 user (show)

Fixed In Version: glusterfs-5.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1582080 (view as bug list)
Environment:
Last Closed: 2018-10-23 15:09:43 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Kotresh HR 2018-05-21 17:29:14 UTC
Description of problem:
With ctime feature enabled, the first lookup on the file is not healing the gfid if it's not present.

Version-Release number of selected component (if applicable):
mainline

How reproducible:
Always

Steps to Reproduce:
1. Create dist-rep gluster volume (1*2) and mount at /mnt
2. Enable ctime feature
             gluster vol set <vol> utime on
             gluster vol set <vol> ctime on
3. Create a file on both replica brick in the backend (say file)
4. stat /mnt/file

Actual results:
The first stat is giving ENOENT and is not healing gfid

Expected results:
The first stat should heal the gfid

Additional info:

Comment 1 Worker Ant 2018-05-21 17:35:56 UTC
REVIEW: https://review.gluster.org/20052 (posix/ctime: Fix gfid heal on first lookup) posted (#1) for review on master by Kotresh HR

Comment 2 Worker Ant 2018-05-24 06:25:16 UTC
COMMIT: https://review.gluster.org/20052 committed in master by "Amar Tumballi" <amarts@redhat.com> with a commit message- posix/ctime: Fix gfid heal on first lookup

With ctime feature enabled, the gfid is
not healing on first lookup. The fresh
file logic depends on ctime and it was
fetching from backend instead of xattr
with ctime feature enabled. Fixed the
same.

Also fixed a possible hang with inode lock

Change-Id: I020875c0462b284d6fa0e68304a422fa3d6a3e73
fixes: bz#1580532
Signed-off-by: Kotresh HR <khiremat@redhat.com>

Comment 3 Shyamsundar 2018-10-23 15:09:43 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-5.0, please open a new bug report.

glusterfs-5.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://lists.gluster.org/pipermail/announce/2018-October/000115.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.