Bug 158085 - e-d-s rpm spec has some bugs
e-d-s rpm spec has some bugs
Product: Fedora
Classification: Fedora
Component: evolution-data-server (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthew Barnes
Depends On:
  Show dependency treegraph
Reported: 2005-05-18 11:04 EDT by Aaron Gaudio
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: evolution-2.8.0-7.fc6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-11-26 22:47:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Aaron Gaudio 2005-05-18 11:04:23 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.7) Gecko/20050417 Galeon/1.3.20

Description of problem:
The spec file for e-d-s 1.2.2 release 2 contains at least one error and one uncessary hard-coded version string:

soup_version is defined as 2.2.2, but this release of e-d-s apparently requires libsoup 2.2.3 or greater (the configure step will fail without it).

mozilla_build_version is defined as 1.7.6, although 1.7.8 is the latest version of mozilla in FCtest4. There's no reason to hard-code this in the spec file....

%define mozilla_build_version %(pkg-config --modversion mozilla-nss)

will work better, and will always pick up the latest version. If you want to ensure someone doesn't use an old version of mozilla, you could use a hard-coded BuildReq of 'mozilla-nss-devel >= 37:1.7.3' (same for mozilla-nspr-devel), but the mozilla_build_version is used to tell e-d-s where the mozilla headers are, and that requires the actual version currently installed.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. With libsoup 2.2.2 installed (hint it's *not* the latest in FCtest4), try rpm --rebuild the e-d-s sprm.

Actual Results:  Configure will fail because e-d-s requires at least 2.2.3.

Expected Results:  Spec should have an updated build requirement of libsoup 2.2.3, so trying to rebuild the rpm with libsoup 2.2.2 will result in a dependency error.

Additional info:

Also, with the latest mozilla package from FCtest4, configure will fail because it can't find the mozilla nspr headers under 1.7.6 (cause they don't exist). This happens before the libsoup problem is hit.
Comment 1 Dave Malcolm 2005-05-18 13:07:50 EDT
Thanks for this report.

I'm rebuilding with:
- updated (hardcoded) libsoup requirement (reflecting the value in configure.in)
- removal of mozilla_build_version.  It now relies upon the pkg-config tests
from the configure.in to get the correct include and library paths, and so
should work with whatever version of mozilla you're building against.

I'm trying to get this into the final FC4.
Comment 3 Matthias Clasen 2006-11-26 22:47:59 EST
Closing, according to comment 1

Note You need to log in before you can comment on or make changes to this bug.