Bug 158089 - kickstart xconfig does not appear to probe for monitor or set manual resolution
kickstart xconfig does not appear to probe for monitor or set manual resolution
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Chris Lumens
:
Depends On:
Blocks: FC6Target
  Show dependency treegraph
 
Reported: 2005-05-18 11:35 EDT by Orion Poplawski
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-16 13:15:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Orion Poplawski 2005-05-18 11:35:04 EDT
Description of problem:
I use the following generic xconfig line in my kickstart installs:

xconfig --startxonboot --defaultdesktop=KDE --resolution=1600x1200 --depth=24

My hope with this is to end up with a configuration that attempts to use the
maximum possible resolution.  Instead, I end up with something like:

Section "Monitor"
        Identifier   "Monitor0"
        VendorName   "Monitor Vendor"
        ModelName    "Unprobed Monitor"
        DisplaySize  300        230
        HorizSync    31.5 - 37.9
        VertRefresh  50.0 - 61.0
        Option      "dpms"
EndSection

Section "Device"
        Identifier  "Videocard0"
        Driver      "radeon"
        VendorName  "Videocard vendor"
        BoardName   "ATI Radeon 7200"
EndSection

Section "Screen"
        Identifier "Screen0"
        Device     "Videocard0"
        Monitor    "Monitor0"
        DefaultDepth     24
        SubSection "Display"
                Viewport   0 0
                Depth     24
                Modes    "800x600" "640x480"
        EndSubSection
EndSection

It probed the video card, but did not appear to probe the monitor.  I this case
I would have hoped for something like:

Section "Monitor"
        Identifier   "Monitor0"
        VendorName   "Radius"
        ModelName    "RDS1546"
        DisplaySize  300        230
        HorizSync    30.0 - 63.0
        VertRefresh  50.0 - 75.0
        Option      "dpms"
EndSection

Section "Device"
        Identifier  "Videocard0"
        Driver      "radeon"
        VendorName  "Videocard vendor"
        BoardName   "ATI Radeon 7200"
EndSection

Section "Screen"
        Identifier "Screen0"
        Device     "Videocard0"
        Monitor    "Monitor0"
        DefaultDepth     24
        SubSection "Display"
                Viewport   0 0
                Depth     24
                Modes    "1600x1200" "1400x1050" "1280x1024" "1024x768"
"800x600" "640x480"
        EndSubSection
EndSection

Even though this monitor only supports upto 1024x768, this should be
automatically determined by the X server at startup.  Those systems can can
handle greater will automatically do so.

ddcprobe returns:

Videocard DDC probe results
Description:  ATI Technologies Inc. RG6
Memory (MB):  32

Monitor DDC probe results
ID: RDS1546
Name: Radius
Horizontal Sync (kHZ): 30-63
Vertical Sync (HZ)  : 50-75
Width (mm): 300
Height(mm): 230
Comment 1 Chris Lumens 2005-12-08 15:08:35 EST
Do you have a monitor line in your kickstart config file?  Please attach the
whole command section so I can see what's going on.
Comment 2 Orion Poplawski 2005-12-08 15:54:41 EST
No monitor statement.  Basically, I use the same options for many different
hardware configurations, but I basically want the highest possible resolution
made.  I typically have to comment out the Sync rates and add higher resoultions
after install.

install
text
nfs --server=saga --dir=/export/data1/fedora/core/development/i386
lang en_US
keyboard us
network --bootproto=dhcp
rootpw --iscrypted CwU/lYtazWt7E
firewall --disabled
authconfig --enableshadow --enablenis --nisdomain=yp.colorado-research.com
timezone America/Denver
xconfig --startxonboot --defaultdesktop=KDE --resolution=1600x1200 --depth=24
clearpart --linux
part /boot --fstype ext3 --size=50
part / --fstype ext3 --size=4500
part /var --fstype ext3 --size=512
part swap --recommended
part /export --fstype ext3 --size=100 --grow
bootloader --location=mbr
reboot
Comment 3 Chris Lumens 2005-12-13 10:05:42 EST
I've made some modifications to how the xconfig and monitor keywords work.  I
don't think it fixes your problem entirely, but if you could try a rawhide
install , I could see how much more work remains to be done.  In particular, I
have removed the monitor configuration options from xconfig since those were
duplicated by the monitor keyword.  Let me know what results you get and I'll
see what else needs to be changed.
Comment 4 Orion Poplawski 2006-01-20 19:03:12 EST
Think we're making progress.  With a fresh install, got:

Section "Monitor"
        Identifier   "Monitor0"
        VendorName   "Monitor Vendor"
        ModelName    "Dell P992"
        DisplaySize  360        270
        HorizSync    30.0 - 107.0
        VertRefresh  48.0 - 170.0
        Option      "dpms"
EndSection

Section "Device"
        Identifier  "Videocard0"
        Driver      "ati"
        VendorName  "Videocard vendor"
        BoardName   "ATI Technologies Inc Radeon Mobility M7 LW [Radeon Mobility
7500]"
EndSection

Section "Screen"
        Identifier "Screen0"
        Device     "Videocard0"
        Monitor    "Monitor0"
        DefaultDepth     24
        SubSection "Display"
                Viewport   0 0
                Depth     24
                Modes    "1600x1200" "1400x1050" "1280x960" "1280x800"
"1280x1024" "1152x
864" "1152x768" "1024x768" "800x600" "640x480"
        EndSubSection
EndSection

Which is basically what I want, I think.  However, this is a laptop that is
currently docked.  I imaging that the DisplaySize, HorizSync, and VertRefresh
lines in the Monitor section are going to cause problems when I boot undocked. 
I would venture a guess that it is better to comment those lines out unless a
monitor keyword specifies certain values (or you are unable to probe the monitor
and you need to put in safe defaults).  If you can probe the monitor at install,
X should be able to probe at startup and determine appropriate modes.
Comment 5 Orion Poplawski 2006-02-15 17:58:02 EST
Another datapoint:

ks:

xconfig --startxonboot --defaultdesktop=KDE --resolution=1600x1200 --depth=24

anaconda-ks.cfg:

xconfig --driver "ati" --videoram 32768 --resolution 1280x960 --depth 24
--startxonboot
--defaultdesktop kde
monitor --hsync 30-63 --vsync 50-75

xorg.conf:

Section "Monitor"
        Identifier   "Monitor0"
        VendorName   "Monitor Vendor"
        ModelName    "Radius"
        DisplaySize  300        230
        HorizSync    30.0 - 63.0
        VertRefresh  50.0 - 75.0
        Option      "dpms"
EndSection

Section "Device"
        Identifier  "Videocard0"
        Driver      "ati"
        VendorName  "Videocard vendor"
        BoardName   "ATI Technologies Inc Radeon RV100 QY [Radeon 7000/VE]"
EndSection

Section "Screen"
        Identifier "Screen0"
        Device     "Videocard0"
        Monitor    "Monitor0"
        DefaultDepth     24
        SubSection "Display"
                Viewport   0 0
                Depth     24
                Modes    "1280x960" "1024x768" "800x600" "640x480"
        EndSubSection
EndSection


The problem is that the LCD panel hooked up has a max resolution of 1024x768, so
I had to remove the "1280x960" resolution.  That's fine.  *perhaps* an X bug.

I would still like the option of not probing the monitor and so not having
DisplaySize, HorizSync, and VertRefresh set to anything though and so rely on X
probing at run time for ease of changing monitors.
Comment 6 Jeremy Katz 2006-02-27 16:30:49 EST
Orion -- although it would be nice to be able to do that, it requires
significant changes to how X works.  I'm hopeful that for FC6, that will be
done, though.
Comment 7 Orion Poplawski 2006-02-27 16:45:19 EST
That's fine.  I'm happy to do any needed testing...
Comment 8 Chris Lumens 2006-08-08 11:50:16 EDT
What's the status of this on FC6 test 2?
Comment 9 Orion Poplawski 2006-08-08 16:02:05 EDT
Starting with:

xconfig --startxonboot --defaultdesktop=KDE --resolution=1600x1200 --depth=24

I ended up with:

# XFree86 4 configuration created by pyxf86config

Section "ServerLayout"
        Identifier     "Default Layout"
        Screen      0  "Screen0" 0 0
        InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "InputDevice"
        Identifier  "Keyboard0"
        Driver      "kbd"
        Option      "XkbModel" "pc105"
        Option      "XkbLayout" "us"
EndSection

Section "Device"
        Identifier  "Videocard0"
        Driver      "neomagic"
EndSection

Section "Screen"
        Identifier "Screen0"
        Device     "Videocard0"
        DefaultDepth     24
EndSection

on an old Dell Latitude with a NeoMagic video controller.  This looks very
different that what I've seen in the past.

In this case X decides to drive a 1280x1024 but I get garbage on the screen. 
This is probably a bad test of this functionality though.  I'll try again on
somewhat more modern hardware. 
Comment 10 Orion Poplawski 2006-08-08 16:11:02 EDT
Yeah, ddcprobing on this fails so it's a bad test.  It is nice though that it
seems to make minimal configs to X so that it tries to do stuff automatically. 
But perhaps in this case we actually do need some kind of safe fall back.
Comment 11 Chris Lumens 2007-02-01 18:00:29 EST
Well that code's a mess.  Now if you have a kickstart file and specify a
--resolution=, it will preserve that value in the xorg.conf that gets written
out onto the installed system.  Just passing a resolution to anaconda will
change the resolution that anaconda itself runs at, but won't do anything about
the final xorg.conf.  Of course if you don't specify a resolution, nothing will
get written out.

This will be in the next build of rhpxl and anaconda.

Note You need to log in before you can comment on or make changes to this bug.