Bug 158091 - File is corrupted with no error message during copy or disk check.
File is corrupted with no error message during copy or disk check.
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: lvm2 (Show other bugs)
3
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Alasdair Kergon
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-05-18 12:18 EDT by Michael Setzer II
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-23 10:28:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Setzer II 2005-05-18 12:18:06 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8b2) Gecko/20050512 Firefox/1.0+

Description of problem:
File corruption - Fedora Core 3
shutdown -r -F now gives no errors.

Image file created on a P4 system with no problem after
earlier corruption on AMD 64 machine that was working before.

13,585,246,488 fc3ll.lzo

File copied to AMD 64 machine using ncftp no error in copy,
but then fails lzop -t <fc3ll.lzo test with checksum error.

Then copied file to another system to compare original file to
file from amd 64.

System was working fine with 4 images, but now fails, on image 
creation,
images that worked before, and even trying to blank drive with
dd if=/dev/zero of=/0bits (Machine froze after about 8.3GB)

Here is the comparision of the bad file versus good file.
Note: all addresses end with 3 and all differences are either
08 hex or 80 hex?

The system is less than 1 month old, and is an MSI 6741 
motherboard with a 250GB Maxtor Diamond Max 10 6B250R0 drive.

Other than this error, which was working earlier with 4 pervious
images, but now even those fail the lzop test.

Ran the Gyum, and it went thru the install of the new updates with 
no problem.

Any suggestions on what tests might help to find what is causing the
problem. Does it look like motherboard, harddisk, hdparm, etc.


Comparing files fc3ll.lzo and \FC3LL.LZO
Address   64File P4   Diff
27B5C8B3:   62   E2    80
4BE758B3:   2C   AC    80
4BE761A3:   64   6C     8
4BE768D3:   0E   8E    80
785F13C3:   05   0D     8
785F1943:   E5   ED     8
A1A788B3:   44   C4    80
F3543943:   F3   FB     8
F35448D3:   6B   EB    80
FE52A1A3:   B3   BB     8
171BB943:   F6   FE     8
2ECBA8B3:   6D   ED    80
4009F8B3:   4C   CC    80
400A08D3:   17   97    80
8E3A71D3:   79   F9    80
8E3A73C3:   E0   E8     8
8E3A78B3:   67   E7    80
92123823:   67   6F     8
921238B3:   6C   EC    80
BB3923C3:   23   2B     8
BB392943:   11   19     8
BCEA48D3:   3E   BE    80
BE538943:   27   2F     8
BE5398D3:   6F   EF    80
E3BC71D3:   1A   9A    80
E3BC73C3:   07   0F     8
ECB0E1A3:   60   68     8
0CD6A8B3:   34   B4    80
0CD6A943:   F7   FF     8
0E8898D3:   0B   8B    80
1C65F3C3:   B0   B8     8
1C65F8B3:   71   F1    80
1C6C81A3:   13   1B     8
357BD8B3:   11   91    80
371BE1A3:   63   6B     8
4AB5E8B3:   50   D0    80
4AB5E943:   F7   FF     8
78AB41A3:   01   09     8
78AB48D3:   45   C5    80
87EB63C3:   21   29     8
88B971A3:   E2   EA     8
88B978D3:   4A   CA    80
A74861A3:   C5   CD     8
B11443C3:   70   78     8
B1C9F1A3:   33   3B     8
B1C9F8D3:   6F   EF    80
D5CC9943:   01   09     8
DA7ED1A3:   21   29     8
03A658B3:   0A   8A    80
03A668D3:   61   E1    80
03AEF873:   6C   EC    80
1A7B0143:   2E   AE    80
1A7B03C3:   37   3F     8
1A7B0943:   24   2C     8

Thanks.


Version-Release number of selected component (if applicable):


How reproducible:
Sometimes

Steps to Reproduce:
New AMD x86_64 system with 1GB Ram and 250GB hard drive. The system was built to hold multiple G4L disk images that work fine on system with a P4 and 40GB drive. Was working fine, but then the 5th 13GB image file was corrupted (failed lzop -t), and so did the earlier files that were working fine. The Description shows the file is now somehow getting corrupted, but I don't know how or why.

Actual Results:  The description shows the strange corruption. 

Expected Results:  The file should be corrupted. 

Additional info:

The original error appeared with the g4l image program I've been working on, but it also appears if just copying an image file. 

I've only been able to put two images on my other systems, since they only have 40GB drives. The corruption with no error message seems to be a big problem.
Comment 1 Michael Setzer II 2005-05-22 12:06:42 EDT
Problem linked to bad memory modual. Tested system with memtest before
installing, but ran test again, and one of the two 512MB moduals no produces
errors. But no error was recorded outside of memtest. 

Note You need to log in before you can comment on or make changes to this bug.