Bug 1581 - Fails test of AnyDBM module
Fails test of AnyDBM module
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: perl (Show other bugs)
6.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Crutcher Dunnavant
:
: 1768 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-03-17 14:37 EST by David Lawrence
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-06-24 14:50:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Derek Tattersall 1999-03-17 14:37:57 EST
The build of perl5 fails make test with the test of the
AnyDBM module.
Comment 1 Derek Tattersall 1999-03-23 14:07:59 EST
This is on the alpha platform

base/cond...........ok
base/if.............ok
base/lex............ok
base/pat............ok
base/rs.............ok, 4 subtests skipped
base/term...........ok
comp/cmdopt.........ok
comp/colon..........ok
comp/cpp............ok
comp/decl...........ok
comp/multiline......ok
comp/package........ok
comp/proto..........ok
comp/redef..........ok
comp/require........ok
comp/script.........ok
comp/term...........ok
comp/use............ok
cmd/elsif...........ok
cmd/for.............ok
cmd/mod.............ok
cmd/subval..........ok
cmd/switch..........ok
cmd/while...........ok
io/argv.............ok
io/dup..............ok
io/fs...............ok
io/inplace..........ok
io/iprefix..........ok
io/pipe.............ok
io/print............ok
io/read.............ok
io/tell.............ok
op/append...........ok
op/arith............ok
op/array............ok
op/assignwarn.......ok
op/auto.............ok
op/avhv.............ok
op/bop..............ok
op/chop.............ok
op/closure..........ok
op/cmp..............dubious
        Test returned status 0 (wstat 136, 0x88)
        test program seems to have generated a core
op/cond.............ok
op/context..........ok
op/defins...........ok
op/delete...........ok
op/die..............ok
op/die_exit.........ok
op/do...............ok
op/each.............ok
op/eval.............ok
op/exec.............ok
op/exp..............ok
op/flip.............ok
op/fork.............ok
op/glob.............ok
op/goto.............ok
op/goto_xs..........ok
op/groups...........ok
op/gv...............ok
op/hashwarn.........ok
op/inc..............ok
op/index............ok
op/int..............ok
op/join.............ok
op/list.............ok
op/local............ok
op/magic............ok, 4 subtests skipped
op/method...........ok
op/misc.............ok
op/mkdir............ok
op/my...............ok
op/nothread.........ok
op/oct..............ok
op/ord..............ok
op/pack.............ok
op/pat..............ok
op/pos..............ok
op/push.............ok
op/quotemeta........ok
op/rand.............ok
op/range............ok
op/read.............ok
op/readdir..........ok
op/recurse..........ok
op/ref..............ok
op/regexp...........ok
op/regexp_noamp.....ok
op/repeat...........ok
op/runlevel.........ok
op/sleep............ok
op/sort.............ok
op/splice...........ok
op/split............ok
op/sprintf..........ok
op/stat.............ok
op/study............ok
op/subst............ok
op/substr...........ok
op/sysio............ok
op/taint............ok, 6 subtests skipped
op/tie..............ok
op/tiearray.........ok
op/tiehandle........ok
op/time.............ok
op/undef............ok
op/universal........ok
op/unshift..........ok
op/vec..............ok
op/wantarray........ok
op/write............ok
pragma/constant.....ok
pragma/locale.......ok
pragma/overload.....ok
pragma/strict.......ok
pragma/subs.........ok
pragma/warning......ok
lib/abbrev..........ok
lib/anydbm..........FAILED test 12
        Failed 1/12 tests, 91.67% okay
lib/autoloader......ok
lib/basename........ok
lib/bigint..........ok
lib/bigintpm........ok
lib/cgi-form........ok
lib/cgi-function....ok
lib/cgi-html........ok
lib/cgi-request.....ok
lib/checktree.......ok
lib/complex.........ok
lib/db-btree........ok
lib/db-hash.........ok
lib/db-recno........ok
lib/dirhand.........ok
lib/dosglob.........ok
lib/dumper-ovl......ok
lib/dumper..........ok
lib/english.........ok
lib/env.............ok
lib/errno...........ok
lib/fields..........ok
lib/filecache.......ok
lib/filecopy........ok
lib/filefind........ok
lib/filehand........FAILED test 3
        Failed 1/11 tests, 90.91% okay
lib/filepath........ok
lib/filespec........ok
lib/findbin.........ok
lib/gdbm............ok
lib/getopt..........ok
lib/h2ph............ok
lib/hostname........ok
lib/io_dup..........ok
lib/io_pipe.........ok
lib/io_sel..........ok
lib/io_sock.........ok
lib/io_taint........ok
lib/io_tell.........ok
lib/io_udp..........ok
lib/io_xs...........ok
lib/ipc_sysv........ok
lib/ndbm............skipping test on this platform
lib/odbm............skipping test on this platform
lib/opcode..........ok
lib/open2...........ok
lib/open3...........ok
lib/ops.............ok
lib/parsewords......ok
lib/ph..............ok
lib/posix...........FAILED test 2
        Failed 1/18 tests, 94.44% okay
lib/safe1...........ok
lib/safe2...........ok
lib/sdbm............ok
lib/searchdict......ok
lib/selectsaver.....ok
lib/socket..........ok
lib/soundex.........ok
lib/symbol..........ok
lib/texttabs........ok
lib/textwrap........ok
lib/thread..........skipping test on this platform
lib/tie-push........ok
lib/tie-stdarray....ok
lib/tie-stdpush.....ok
lib/timelocal.......ok
lib/trig............ok
Failed Test  Status Wstat Total Fail  Failed  List of failed
-------------------------------------------------------------------------------
lib/anydbm.t                 12    1   8.33%  12
lib/filehand.t               11    1   9.09%  3
lib/posix.t                  18    1   5.56%  2
op/cmp.t          0   136    ??   ??       %  ??
3 tests skipped, plus 14 subtests skipped.
Comment 2 Cristian Gafton 1999-04-01 00:56:59 EST
*** Bug 1768 has been marked as a duplicate of this bug. ***

perl Script that works in 5.2 no longer works in 5.9,
getting errors opening db files, debug output is below. If
more is needed, let me know.

  DB<1> main::(./foetus:97):    close PASS;
  DB<1> main::(./foetus:100):
$stuff=tie(%stuff,'DB_File',"$dbfile",O_CREAT|O_RDWR,0664,$DB_HASH)
|| die "Error: Can't open dbfile: $dbfile\n";
  DB<1>
Fcntl::AUTOLOAD(/usr/lib/perl5/5.00502/i386-linux/Fcntl.pm:118):
118:        (my $constname = $AUTOLOAD) =~ s/.*:://;
  DB<1>
Fcntl::AUTOLOAD(/usr/lib/perl5/5.00502/i386-linux/Fcntl.pm:119):
119:        my $val = constant($constname, 0);
  DB<1>
Fcntl::AUTOLOAD(/usr/lib/perl5/5.00502/i386-linux/Fcntl.pm:120):
120:        if ($! != 0) {
  DB<1>
Fcntl::AUTOLOAD(/usr/lib/perl5/5.00502/i386-linux/Fcntl.pm:131):
131:        *$AUTOLOAD = sub { $val };
  DB<1>
Fcntl::AUTOLOAD(/usr/lib/perl5/5.00502/i386-linux/Fcntl.pm:132):
132:        goto &$AUTOLOAD;
  DB<1>
Fcntl::__ANON__(/usr/lib/perl5/5.00502/i386-linux/Fcntl.pm:131):
131:        *$AUTOLOAD = sub { $val };
  DB<1>
Fcntl::AUTOLOAD(/usr/lib/perl5/5.00502/i386-linux/Fcntl.pm:118):
118:        (my $constname = $AUTOLOAD) =~ s/.*:://;
  DB<1>
Fcntl::AUTOLOAD(/usr/lib/perl5/5.00502/i386-linux/Fcntl.pm:119):
119:        my $val = constant($constname, 0);
  DB<1>
Fcntl::AUTOLOAD(/usr/lib/perl5/5.00502/i386-linux/Fcntl.pm:120):
120:        if ($! != 0) {
  DB<1>
Fcntl::AUTOLOAD(/usr/lib/perl5/5.00502/i386-linux/Fcntl.pm:131):
131:        *$AUTOLOAD = sub { $val };
  DB<1>
Fcntl::AUTOLOAD(/usr/lib/perl5/5.00502/i386-linux/Fcntl.pm:132):
132:        goto &$AUTOLOAD;
  DB<1>
Fcntl::__ANON__(/usr/lib/perl5/5.00502/i386-linux/Fcntl.pm:131):
131:        *$AUTOLOAD = sub { $val };
  DB<1>
DB_File::TIEHASH(/usr/lib/perl5/5.00502/i386-linux/DB_File.pm:260):
260:        tie_hash_or_array(@_) ;
  DB<1>
DB_File::tie_hash_or_array(/usr/lib/perl5/5.00502/i386-linux/DB_File.pm:241):
241:        my (@arg) = @_ ;
  DB<1>
DB_File::tie_hash_or_array(/usr/lib/perl5/5.00502/i386-linux/DB_File.pm:242):
242:        my $tieHASH = ( (caller(1))[3] =~ /TIEHASH/ ) ;
  DB<1>
DB_File::tie_hash_or_array(/usr/lib/perl5/5.00502/i386-linux/DB_File.pm:245):
245:            if @arg >= 5 && ref $arg[4] && $arg[4] =~
/=HASH/ && tied %{ $arg[4] } ;
  DB<1>
DB_File::tie_hash_or_array(/usr/lib/perl5/5.00502/i386-linux/DB_File.pm:244):
244:        $arg[4] = tied %{ $arg[4] }
  DB<1>
DB_File::tie_hash_or_array(/usr/lib/perl5/5.00502/i386-linux/DB_File.pm:244):
244:        $arg[4] = tied %{ $arg[4] }
  DB<1>
DB_File::tie_hash_or_array(/usr/lib/perl5/5.00502/i386-linux/DB_File.pm:248):
248:        if ($db_version > 1 and defined $arg[4] and
$arg[4] =~ /RECNO/ and
249:            $arg[1] and ! -e $arg[1]) {
  DB<1>
DB_File::tie_hash_or_array(/usr/lib/perl5/5.00502/i386-linux/DB_File.pm:255):
255:        DoTie_($tieHASH, @arg) ;
  DB<1> Error: Can't open dbfile: stuff.db


------- Additional Comments From pbrown@redhat.com  03/30/99 16:42 -------
Cristian, I think this relates to bug #1581 rather strongly.
Comment 3 Cristian Gafton 1999-06-24 14:50:59 EDT
The perl in Red Hat Linux 6.0 is linked against the new berkley DB
version 2.

The old databasea need to rebuilt from raw data and/or ported using
db_dump
Comment 4 smanes 1999-08-05 13:00:59 EDT
This solution (port the databases) won't fix Perl 5.005.03's (as well
as the current dev version's) build complaints nor will it the placate
some of the perl modules like 'libwww' which are griping about this as
well.  What I could use are simple, Dick and Jane instructions on
fixing this in Redhat's libs, whether it's db1, db2 or whatever.
Comment 5 smanes 1999-08-05 13:07:59 EDT
This solution (port the databases) won't fix Perl 5.005.03's (as well
as the current dev version's) build complaints nor will it the placate
some of the perl modules like 'libwww' which are griping about this as
well.  What I could use are simple, Dick and Jane instructions on
fixing this in Redhat's libs, whether it's db1, db2 or whatever.

Note You need to log in before you can comment on or make changes to this bug.