Bug 1581026 - No clusterservicebroker created after install service-catalog & template-service-broker in 'cluster up' env
Summary: No clusterservicebroker created after install service-catalog & template-serv...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Service Broker
Version: 3.10.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 3.10.0
Assignee: jkim
QA Contact: XiuJuan Wang
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-22 03:04 UTC by XiuJuan Wang
Modified: 2018-07-30 19:16 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
undefined
Clone Of:
Environment:
Last Closed: 2018-07-30 19:16:09 UTC
Target Upstream Version:


Attachments (Terms of Use)
less_clusterservicebroker_error (17.63 KB, text/plain)
2018-05-22 03:06 UTC, XiuJuan Wang
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:1816 None None None 2018-07-30 19:16:29 UTC

Description XiuJuan Wang 2018-05-22 03:04:57 UTC
Description of problem:
No clusterservicebroker created after install service-catalog & template-service-broker in 'oc cluster up' env

Version-Release number of selected component (if applicable):
Server https://**:8443
openshift v3.10.0-0.50.0
kubernetes v1.10.0+b81c8f8


How reproducible:
always

Steps to Reproduce:
1.Setup env with enabled tsb
#oc cluster up  --image='brew-pulp-**/openshift3/ose-${component}:${version}'   --loglevel=8 --enable='*,service-catalog,template-service-broker'
2.Check clusterservicebroker and clusterserviceclass
3.

Actual results:
# oc get clusterservicebroker
No resources found.
[root@preserve-devexp-cluster-up ~]# oc get clusterserviceclass
No resources found.

Expected results:
Should created these resources

Additional info:

Comment 1 XiuJuan Wang 2018-05-22 03:06:01 UTC
Created attachment 1439788 [details]
less_clusterservicebroker_error

Comment 2 Michal Fojtik 2018-05-23 08:32:49 UTC
Fix: https://github.com/openshift/origin/pull/19808

Comment 4 XiuJuan Wang 2018-05-31 09:00:07 UTC
This issue has fixed in 
v3.10.0-0.54.0
kubernetes v1.10.0+b81c8f8

Comment 6 XiuJuan Wang 2018-06-04 03:30:29 UTC
As comment #4, move this bug to verified

Comment 8 errata-xmlrpc 2018-07-30 19:16:09 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:1816


Note You need to log in before you can comment on or make changes to this bug.