Bug 1581035 - posix/ctime: Mtime is not updated on setting it to older date
Summary: posix/ctime: Mtime is not updated on setting it to older date
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: posix
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kotresh HR
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1582531
TreeView+ depends on / blocked
 
Reported: 2018-05-22 05:00 UTC by Kotresh HR
Modified: 2018-10-23 15:09 UTC (History)
1 user (show)

Fixed In Version: glusterfs-5.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1582531 (view as bug list)
Environment:
Last Closed: 2018-10-23 15:09:43 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Kotresh HR 2018-05-22 05:00:13 UTC
Description of problem:
With ctime feature enabled, mtime is not updated when it's set to older date than the existing time.

Version-Release number of selected component (if applicable):
mainline

How reproducible:
Always

Steps to Reproduce:
1. Create gluster volume
2. Enable ctime feature as follows
                gluster vol set <vol> ctime on
                gluster vol set <vol> utime on
3. Mount the volume at say /mnt
4  touch -d "@946681200" /mnt/file1

Actual results:
mtime of /mnt/file1 is not updated to 946681200

Expected results:
mtime of /mnt/file1 should be updated to 946681200

Additional info:

Comment 1 Worker Ant 2018-05-22 05:04:31 UTC
REVIEW: https://review.gluster.org/20055 (posix/ctime: Fix updating mtime older time) posted (#1) for review on master by Kotresh HR

Comment 2 Worker Ant 2018-05-25 05:32:25 UTC
COMMIT: https://review.gluster.org/20055 committed in master by "Amar Tumballi" <amarts@redhat.com> with a commit message- posix/ctime: Fix updating mtime to older time

With ctime feature enabled, the mtime is not
updated when it's set to time older than the
existing one. Fixed the same. But the ctime
is not allowed to change to older dates.

fixes: bz#1581035
Change-Id: If520922df42d6ce084c8df3046c138f8367164e5
Signed-off-by: Kotresh HR <khiremat@redhat.com>

Comment 3 Shyamsundar 2018-10-23 15:09:43 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-5.0, please open a new bug report.

glusterfs-5.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://lists.gluster.org/pipermail/announce/2018-October/000115.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.