Bug 1581042 - Deploy logging failed on RUNNING HANDLER [openshift_logging_elasticsearch : assert]
Summary: Deploy logging failed on RUNNING HANDLER [openshift_logging_elasticsearch : a...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Logging
Version: 3.10.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 3.10.0
Assignee: ewolinet
QA Contact: Qiaoling Tang
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-22 05:22 UTC by Qiaoling Tang
Modified: 2018-07-30 19:16 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
undefined
Clone Of:
Environment:
Last Closed: 2018-07-30 19:16:14 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:1816 None None None 2018-07-30 19:16:51 UTC

Description Qiaoling Tang 2018-05-22 05:22:15 UTC
Description of problem:
Deploy logging by using ansible, it threw an error, the message is:
RUNNING HANDLER [openshift_logging_elasticsearch : assert] *********************
Tuesday 22 May 2018  03:04:21 +0000 (0:00:00.028)       0:06:32.085 *********** 
fatal: [$master-url]: FAILED! => {"failed": true, "msg": "The conditional check 'not _pod_status.failed' failed. The error was: error while evaluating conditional (not _pod_status.failed): 'dict object' has no attribute 'failed'"}

But after running ansible-playbook, all pods in openshift-logging are running.
# oc get pod -n openshift-logging
NAME                                      READY     STATUS    RESTARTS   AGE
logging-curator-1-9c8x4                   1/1       Running   0          25m
logging-es-data-master-zx7zarh1-1-4rcj8   2/2       Running   0          24m
logging-fluentd-65j5x                     1/1       Running   0          24m
logging-fluentd-wxjqf                     1/1       Running   0          24m
logging-kibana-1-9pw2j                    2/2       Running   0          26m


Version-Release number of selected component (if applicable):
openshift v3.10.0-0.50.0
kubernetes v1.10.0+b81c8f8

openshift-ansible-3.10.0-0.50.0.git.0.bd68ade.el7.noarch

logging-curator-v3.10.0-0.50.0.0
logging-elasticsearch-v3.10.0-0.50.0.0
logging-fluentd-v3.10.0-0.50.0.0

How reproducible:
Always

Steps to Reproduce:
1.Deploy logging, set openshift_logging_install_logging=true in inventory and run ansible-playbook
2.
3.

Actual results:
The ansible-playbook failed

Expected results:
Asible-playbook could run successfully without any error.

Additional info:

Comment 2 Qiaoling Tang 2018-05-28 08:15:53 UTC
Verified on openshift v3.10.0-0.53.0.

Comment 4 errata-xmlrpc 2018-07-30 19:16:14 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:1816


Note You need to log in before you can comment on or make changes to this bug.