Bug 1581052 - Should specify the namespace when install the ASB with dashboard redirector
Summary: Should specify the namespace when install the ASB with dashboard redirector
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Service Broker
Version: 3.10.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 3.10.0
Assignee: Dylan Murray
QA Contact: Jian Zhang
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-22 05:31 UTC by Jian Zhang
Modified: 2018-07-30 19:16 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
undefined
Clone Of:
Environment:
Last Closed: 2018-07-30 19:16:14 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:1816 None None None 2018-07-30 19:16:51 UTC

Description Jian Zhang 2018-05-22 05:31:56 UTC
Description of problem:
The default namespace of the "dashboard redirector" is "ansible-service-broker", but it's non-exist for OCP cluster, so we should set it to "openshift-ansible-service-broker" in openshift-ansible.

Version-Release number of selected component (if applicable):
openshift-ansible-3.10.0-0.47.0

How reproducible:
always


Steps to Reproduce:
1. Install the ASB with "ansible_service_broker_enable_dashboard_redirector=true"
2. Check the configure of the dashboard-redirector.

Actual results:
#oc edit dc/asb
...
      - command:
        - dashboard-redirector
        image: registry.reg-aws.openshift.com:443/openshift3/ose-ansible-service-broker:v3.10.0

Expected results:
      - command:
        - dashboard-redirector
        - --namespace
        - openshift-ansible-service-broker
        image: registry.reg-aws.openshift.com:443/openshift3/ose-ansible-service-broker:v3.10.0


Additional info:

Comment 1 Jian Zhang 2018-05-22 05:48:35 UTC
I submit a PR(https://github.com/openshift/openshift-ansible/pull/8468) to fix this, looking forward your comments.

Comment 2 openshift-github-bot 2018-05-22 08:10:31 UTC
Commits pushed to master at https://github.com/openshift/openshift-ansible

https://github.com/openshift/openshift-ansible/commit/65c87e70fa378e6a46050c7c29bec18a83dfe758
bug 1581052: specify the namespace

https://github.com/openshift/openshift-ansible/commit/7848be798d319c72d83a16d28846b576a28ec9e6
Merge pull request #8468 from jianzhangbjz/dashboard

bug 1581052: specify the namespace

Comment 3 Dylan Murray 2018-05-22 12:51:46 UTC
Thanks for the PR! Looks great.

Comment 4 Jian Zhang 2018-05-31 03:16:34 UTC
Change status to "ON_QA" since the fixed PR has merged into openshift-ansible-3.10.0-0.54.0 version.

Comment 5 Jian Zhang 2018-05-31 03:19:10 UTC
Verify it.

Enable it in inventory file:
...
ansible_service_broker_enable_dashboard_redirector=true
ansible_service_broker_install=true

#ansible-playbook -i qe-inventory-host-file playbooks/openshift-service-catalog/config.yml

Installation works well.
[root@qe-jiazha-31master-etcd-1 ~]# oc get route
NAME       HOST/PORT                                                                PATH      SERVICES   PORT      TERMINATION   WILDCARD
asb-1338   asb-1338-openshift-ansible-service-broker.apps.0530-ngj.qe.rhcloud.com             asb        1338      reencrypt     None
dr-1337    dr-1337-openshift-ansible-service-broker.apps.0530-ngj.qe.rhcloud.com              asb        1337                    None
[root@qe-jiazha-31master-etcd-1 ~]# oc get pods
NAME          READY     STATUS    RESTARTS   AGE
asb-1-24tjs   2/2       Running   0          53s

Comment 7 errata-xmlrpc 2018-07-30 19:16:14 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:1816


Note You need to log in before you can comment on or make changes to this bug.