Bug 158109 - fc4test3 install not possible with Geforce 6200 video card
fc4test3 install not possible with Geforce 6200 video card
Status: CLOSED DUPLICATE of bug 157715
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
4
i386 Linux
medium Severity high
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-05-18 15:12 EDT by Mufit Eribol
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-24 09:39:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
working xorg.conf (2.71 KB, text/plain)
2005-05-19 15:56 EDT, Mufit Eribol
no flags Details
Xorg.0.log for Option "XaaNoOffscreenPixmaps" (46.89 KB, text/plain)
2005-05-19 15:58 EDT, Mufit Eribol
no flags Details
Xorg.0.log for Option "XaaNoScreenToScreenCopy" (46.87 KB, text/plain)
2005-05-19 15:59 EDT, Mufit Eribol
no flags Details

  None (edit)
Description Mufit Eribol 2005-05-18 15:12:28 EDT
Description of problem: During a fresh install, x server starts with a mouse
cursor, white background and nothing else. Install process can not go on.

How reproducible: Always (same problem also with fc4test1 and fc4test2)

Steps to Reproduce:
1. Use Geforce 6200 video card
2. Boot from first disk of fc4test3 for installation
  
Actual results: X starts only with white background with mouse cursor.

Expected results: X should start with the relevant windows, buttons etc
necessary for further installation selections.

Additional info: Anaconda recognises video card as Geforce 6200
Comment 1 Mike A. Harris 2005-05-18 20:39:17 EDT
This appears to be a duplicate of bug #157715, only it is reported on
x86_64.  They could be different issues, but it could be the same issue
on multiple architectures too.  It is assumed that this is a video driver
bug of some sort, and that it is probably not specific to install time.
Please do a text mode installation, and then configure X afterwards for
the following tests:

Run:  system-config-display --reconfig

Then:
Test X and confirm wether the problem occurs or not.  If so, can you
try adding the following to the driver section of your xorg.conf:

    Option "XaaNoOffscreenPixmaps"

Restart the server and see if the problem still remains.  If it doesn't
prevent the issue, comment that option out and try the following option
instead:

    Option "XaaNoScreenToScreenCopy"

Again restart and test.  If the problem still occurs, try putting both
of these options in there and testing again.  Indicate if that solves
the problem.

If none of these tests solve the problem, try using Option "noaccel".

Which of the above work around the problem if any?

Please attach your X server config file and a log file from one of the
runs, as individual uncompressed file attachments using the link below.
Comment 2 Mufit Eribol 2005-05-19 15:56:00 EDT
Created attachment 114585 [details]
working xorg.conf
Comment 3 Mufit Eribol 2005-05-19 15:58:14 EDT
Created attachment 114587 [details]
Xorg.0.log for Option "XaaNoOffscreenPixmaps"
Comment 4 Mufit Eribol 2005-05-19 15:59:19 EDT
Created attachment 114588 [details]
 Xorg.0.log for Option "XaaNoScreenToScreenCopy"
Comment 5 Mufit Eribol 2005-05-19 16:07:04 EDT
system-config-display --reconfig => gave black screen with mouse cursor. Hard
reset to get out.

"startx" resulted in blue screen with mouse cursor. Hard reset was the only way
to get out.

In "Device" section of xorg.conf
Option "XaaNoOffscreenPixmaps" => Some startup Gnome icons came up but nothing
else other than mouse cursor. Again hard reset to get out.

Option "XaaNoScreenToScreenCopy" => X started as expected.

Please find attached xorg.conf and log files for your information.

If you need any further try please let me know.
Comment 6 Mike A. Harris 2005-05-24 09:39:26 EDT
Thanks for the config and logs.  This confirms a problem reported by another
user as well.  I think we'll probably use "XaaNoScreenToScreenCopy" by default
for these chips for FC4, as it's been confirmed to work around the bug.
Hopefully, the "nv" driver maintainer can resolve the driver bug in a future
update as well.

*** This bug has been marked as a duplicate of 157715 ***

Note You need to log in before you can comment on or make changes to this bug.