Bug 1581115 - master config after upgrade should be the same with fresh installation
Summary: master config after upgrade should be the same with fresh installation
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Cluster Version Operator
Version: 3.10.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 3.10.0
Assignee: Vadim Rutkovsky
QA Contact: liujia
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-22 08:01 UTC by liujia
Modified: 2018-07-30 19:16 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-07-30 19:16:14 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:1816 None None None 2018-07-30 19:16:51 UTC

Description liujia 2018-05-22 08:01:41 UTC
Description of problem:
Upgrade ocp v3.9 to v3.10. A admission plugin config in master-config.yaml has been removed after upgrade. 

On v3.10 master hosts which upgraded from v3.9
# diff pre.cfg post.cfg 
26,30d25
<     PodPreset:
<       configuration:
<         apiVersion: v1
<         disable: false
<         kind: DefaultAdmissionConfig

# cat /tmp/pre.cfg |grep -A 5 PodPreset
    PodPreset:
      configuration:
        apiVersion: v1
        disable: false
        kind: DefaultAdmissionConfig
    RunOnceDuration:
# cat /etc/origin/master/master-config.yaml|grep PodPreset

On fresh installed v3.10 master host:
# cat /etc/origin/master/master-config.yaml |grep -A 5 PodPreset
    PodPreset:
      configuration:
        apiVersion: v1
        disable: true
        kind: DefaultAdmissionConfig
    openshift.io/ImagePolicy:

# grep -r "PodPreset"
roles/openshift_control_plane/tasks/upgrade.yml:    key: 'admissionConfig.pluginConfig.PodPreset'
roles/openshift_control_plane/templates/master.yaml.v1.j2:    PodPreset:

Checked that, installer has a task to remove admissionConfig.pluginConfig.PodPreset for upgrade(if this change is necessary?), but for fresh installation, PodPreset was set in master config templates.


Version-Release number of the following components:
ansible-2.4.4.0-1.el7ae.noarch
openshift-ansible-3.10.0-0.50.0.git.0.bd68ade.el7.noarch

How reproducible:
always

Steps to Reproduce:
1. Upgrade rpm installed ocp v3.9 to v3.10
2.
3.

Actual results:
admissionConfig.pluginConfig.PodPreset was different between upgrade ocp and fresh installed ocp.

Expected results:
master config after upgrade should be the same with fresh installation

Additional info:
Please attach logs from ansible-playbook with the -vvv flag

Comment 1 Vadim Rutkovsky 2018-05-24 15:46:25 UTC
Confirmed with liggit that its not required anymore on fresh installs

Comment 2 Vadim Rutkovsky 2018-05-24 17:40:55 UTC
Created https://github.com/openshift/openshift-ansible/pull/8520

Comment 3 Vadim Rutkovsky 2018-05-28 08:21:30 UTC
Fix is available in openshift-ansible-3.10.0-0.53.0

Comment 4 liujia 2018-05-29 07:42:16 UTC
Verified on openshift-ansible-3.10.0-0.53.0.git.0.53fe016.el7.noarch

Now from v3.10 fresh installation, no PodPreset in master config. Upgraded env keep the same with fresh installed env.

# cat /etc/origin/master/master-config.yaml |grep PodPreset

Comment 6 errata-xmlrpc 2018-07-30 19:16:14 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:1816


Note You need to log in before you can comment on or make changes to this bug.