Bug 158123 - Anaconda dies with "rpm transaction failed" and "installer exited abnormally"
Anaconda dies with "rpm transaction failed" and "installer exited abnormally"
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: anaconda (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-05-18 16:32 EDT by Steve Seremeth
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-18 21:41:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steve Seremeth 2005-05-18 16:32:51 EDT
Description of problem:
Customized version of ES 4 installer dies under certain circumstances during
kickstart after PXE Boot and after disk formatting segment of kickstart script.
Specifically, I had added two sun jdk rpm's to my installer, and reran the
necessary scripts (genhdlist/pkgorder/genhdlist).  Sun mis-named their java
rpm's and it caused the installer to blow up with only "WARNING: not all
packages in hdlist had order tag" on other virtual console.  

I _did_ get a warning after running genhdlist the 2nd time:
WARNING: ordering not found for jdk-1_5_0_02-linux-i586.rpm

But maybe there could have been a better error message their, or a pointer
towards how to reolve issues like this?

Specifically, I'm just looking for a better error message here -- like even
"file XXX for package XXX not found" or something of that nature during
kickstart.  Sun should have known better, but it would have saved me the better
part of a day if the error message was more accurate/verbose.  All I had to do
to make the installer work was rename the rpm's from jdk-1_5_0_02-linux-i586.rpm
to jdk-1.5.0_02-fcs.i586.rpm following the proper conventions, but it took an
outside pair of eyes after much hassle to figure this out.  Also, the rpms
install fine using rpm -i on a live system.  Only Anaconda doesn't like them.


Version-Release number of selected component (if applicable):
anaconda-10.1.1.13-1

How reproducible:
Every time.  

Steps to Reproduce:
1.  Download sun java rpm (any of them it seems).    
2.  Put in your RedHat/RPMS dir in your build path.
3.  Run genhdlist/pkgorder/genhdlist with appropriate switches.
4.  Add java to your package list in a kickstart script.
5.  Kickstart server against your ks script.

  
Actual results:
Implosion happens right after partitioning segment of install.

Expected results:
Genhdlist or Anaconda to provide better error message to point out rpm misnaming.


Additional info:
Sun should know better, but if this process were documented a little better it
would have saved me a lot of time.
Comment 1 Paul Nasrat 2005-05-18 18:06:26 EDT
I think this is a name != nvr issue

rpm --qf '%{name}-%{version}-%{release}.%{arch}.rpm\n' -qp
jdk-1_5_0_02-linux-i586.rpm

My personal suggestion would be to use the jpackage nosrc.rpm to build the sun
rpms from the binary installer (non-rpm). RHEL 4 and Fedora java/gcj are
designed to be compatible with JPackage standards, so this would allow you to
switch jdks using alternatives with ones provided via RHAPS or the RHEL Extras

http://jpackage.org/rpm.php?id=2546
http://jpackage.org/faq.php
http://jpackage.org/rebuilding.php
Comment 2 Jeremy Katz 2005-05-18 21:41:48 EDT
The problem is that you can get the error for a variety of reasons and the
naming being wrong is just the tip of the iceberg.  Things get handled a little
bit better in the devel tree, though.
Comment 3 Steve Seremeth 2005-05-19 09:05:10 EDT
So are nicer error messages out of the question then, for Anaconda?  This seems
like a pretty worthy issue to resolve, especially since Anaconda is not very
well documented, imho.  This is/was a "name != nvr issue".  

Note You need to log in before you can comment on or make changes to this bug.