Bug 158126 - magma-devel has bogus dependency on magma
magma-devel has bogus dependency on magma
Status: CLOSED WONTFIX
Product: Red Hat Cluster Suite
Classification: Red Hat
Component: magma (Show other bugs)
4
All Linux
low Severity low
: ---
: ---
Assigned To: Chris Feist
Cluster QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-05-18 16:46 EDT by Charlie Brady
Modified: 2009-04-16 16:33 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-26 15:51:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Charlie Brady 2005-05-18 16:46:08 EDT
I wish to build ccs. I'm told that I need to magma-devel. I try to install
magma-devel, but am told:

[charlieb@localhost SRPMS]$ sudo rpm -Uhv /tmp/magma-devel-1.0-0.pre21.7.i386.rpm
error: Failed dependencies:
        magma = 1.0-0.pre21.7 is needed by magma-devel-1.0-0.pre21.7
[charlieb@localhost SRPMS]$ 

Not trusting this information, I install magma-devel without magma. I am able to
build ccs. Therefore magma-devel is useful without magma. Ergo, the dependency
is bogus.
Comment 1 Lon Hohberger 2005-05-20 16:57:18 EDT
Note that you would do better in building ccs against the dynamic libccs.so
instead of the static lib (libccs.a) provided by the -devel package.

The APIs might not change, but the underlying communication mechanism might...
Comment 2 Lon Hohberger 2005-05-20 16:58:04 EDT
and by that, I meant building ccs against the dynamic libmagma.so instead of the
static libmagma.a :)

Sorry, it's been a long week.
Comment 3 Chris Feist 2005-05-25 18:14:20 EDT
Closing as NOTABUG see bz# 158125.
Comment 4 Charlie Brady 2005-05-25 19:35:50 EDT
> Note that you would do better in building ccs against the dynamic libccs.so
> instead of the static lib (libccs.a) provided by the -devel package.

That's just an argument in favour of including the dynamic libraries in the
-devel package (as well as in the non-devel package). Nothing says a file can't
exist in more than one RPM, right (as long as the file has same size, timestamp,
md5sum, perms, etc).

To reiterate, it is a bug, because you're forcing me to install a package which
I don't want or need, just to satisfy an RPM dependency.

Thanks.
Comment 5 Chris Feist 2005-05-26 15:51:10 EDT
See bz #158125 (additional comments).

Closing as WONTFIX.

Note You need to log in before you can comment on or make changes to this bug.