This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 15813 - cdrom install not starting X on C&T 65555
cdrom install not starting X on C&T 65555
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
Brock Organ
Winston gold
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-08-09 09:36 EDT by Andrea Borgia
Modified: 2007-04-18 12:28 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-12-07 20:11:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Heavily customized XF86Config for 6.2 (3.47 KB, text/plain)
2000-08-24 14:37 EDT, Andrea Borgia
no flags Details
X config generated by RC1 installer (14.16 KB, text/plain)
2000-08-24 14:37 EDT, Andrea Borgia
no flags Details
X config generated by me with Xconfigurator in RC1 post-installation checkup (14.16 KB, text/plain)
2000-08-24 14:39 EDT, Andrea Borgia
no flags Details

  None (edit)
Description Andrea Borgia 2000-08-09 09:36:44 EDT
Upgrading from 6.2, the installer starts TUI without asking
(did not happen in 6.2; card is C&T 65555, DDC probe is ok in 6.2, checked now)
Comment 1 Glen Foster 2000-08-09 15:55:23 EDT
This defect is considered MUST-FIX for Winston Gold-release
Comment 2 Matt Wilson 2000-08-14 15:29:52 EDT
Did you catch any messages on why it may fail?  Do you have a PS/2 mouse?
Comment 3 borgia 2000-08-17 07:25:33 EDT
RC1 but not 6.2: "found video card controller unknown" on Alt-F3, then goes TUI.
Comment 4 Michael Fulbright 2000-08-17 11:41:46 EDT
That particular message is ok - it means it didn't find a card that requires the
agpgart module to be loaded.
Comment 5 Michael Fulbright 2000-08-17 11:42:51 EDT
Does Xconfigurator properly setup your X display?
Comment 6 Matt Wilson 2000-08-17 17:36:44 EDT
Does it "click in" to X before going to text mode?  See any X server messages
stream by?
Comment 7 borgia 2000-08-18 02:12:23 EDT
To msf: how do I know that? Xconfigurator still hasn't had a chance to come up at this stage in install...
To msw: no X messages, nada, nil, null, zilch. No screen flashes either.
Comment 8 Matt Wilson 2000-08-18 02:18:35 EDT
how much system ram do you have?  cat /proc/meminfo from VC2
Comment 9 borgia 2000-08-18 02:50:20 EDT
Do you really need the "cat" or is it enough if I tell you? It's a standard Toshiba Satellite 320cds, with 32MB.
Comment 10 Matt Wilson 2000-08-18 02:52:09 EDT
Well, I'd like to know tha the kernel is detecting the amount of ram properly...

Comment 11 borgia 2000-08-18 08:06:21 EDT
Ok, checked: kernel detects all 32MB and has 9MB free when the shell on VC-2 is available.
BTW, another test machine I have has 128MBm, the kernel sees only 64MB (due to the VIA chipset, I guess) and X starts up fine on install.
Comment 12 Matt Wilson 2000-08-21 11:37:09 EDT
On a booted system, run:

python -c "from kudzu import *; probe(CLASS_VIDEO, BUS_UNSPEC, PROBE_ALL)"

and send the output, please.
Comment 13 Matt Wilson 2000-08-21 12:10:40 EDT
Rather, run:

python -c "from kudzu import *; print probe(CLASS_VIDEO, BUS_UNSPEC, PROBE_ALL)"
Comment 14 borgia 2000-08-21 16:10:36 EDT
[(None, 'Card:Chips & Technologies CT65555', 'C&T|F65555 HiQVPro')]
Comment 15 Matt Wilson 2000-08-21 16:31:44 EDT
Ugh, there is no reason why this shouldn't work.  This is a laptop?
Comment 16 borgia 2000-08-22 00:53:34 EDT
Yes, it's a Toshiba Satellite 320cds.
Comment 17 Matt Wilson 2000-08-23 14:29:47 EDT
Could you install it in text mode and send me the X configuration it writes out,
as well as any working X configuration you can come up with?
Comment 18 Andrea Borgia 2000-08-24 14:35:33 EDT
TUI RC1 install: detects card as CT65520, Xconfigurator loops when using custom monitor (so went for similar monitor type), X setup ok.
Comment 19 Andrea Borgia 2000-08-24 14:37:10 EDT
Created attachment 2919 [details]
Heavily customized XF86Config for 6.2
Comment 20 Andrea Borgia 2000-08-24 14:37:57 EDT
Created attachment 2920 [details]
X config generated by RC1 installer
Comment 21 Andrea Borgia 2000-08-24 14:39:14 EDT
Created attachment 2921 [details]
X config generated by me with Xconfigurator in RC1 post-installation checkup
Comment 22 Andrea Borgia 2000-08-27 10:55:54 EDT
Still there in RC2. After the installation, Xconfigurator generates a valid setup.
Comment 23 Michael Fulbright 2000-11-13 11:53:01 EST
Added pbrown because apparently Xconfigurator setup works, but anaconda does
not.  Needs to have a unified solution in the future.
Comment 24 Brent Fox 2000-12-07 20:11:46 EST
This should be fixed with the installer that is currently in CVS.  The new installer tries to use the frame buffer if possible, and this will allow the installer to 
work on many cards that didn't work in the past.  I'm resolving this bug, but please reopen if the problem persists in future versions.
Comment 25 Aaron Brown 2000-12-13 17:20:06 EST
Verified as resolved.

Note You need to log in before you can comment on or make changes to this bug.