Bug 1581388 - master scaleup failed due to 'openshift_is_atomic' is undefined"
Summary: master scaleup failed due to 'openshift_is_atomic' is undefined"
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 3.10.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 3.10.0
Assignee: Michael Gugino
QA Contact: Johnny Liu
URL:
Whiteboard:
Depends On:
Blocks: 1582190
TreeView+ depends on / blocked
 
Reported: 2018-05-22 15:50 UTC by Vikas Laad
Modified: 2019-01-30 00:51 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1582190 (view as bug list)
Environment:
Last Closed: 2018-07-30 19:16:14 UTC
Target Upstream Version:


Attachments (Terms of Use)
ansible log with -vvv (233.42 KB, text/plain)
2018-05-22 15:53 UTC, Vikas Laad
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:1816 None None None 2018-07-30 19:16:51 UTC

Description Vikas Laad 2018-05-22 15:50:25 UTC
Description of problem:
I am trying to do a master scale up and seeing following error

fatal: [ec2-34-219-80-219.us-west-2.compute.amazonaws.com]: FAILED! => {
    "failed": true, 
    "msg": "The task includes an option with an undefined variable. The error was: {{ (openshift_is_atomic | bool) | ternary('/usr/local/bin/oc', 'oc') }}: 'openshift_is_atomic' is undefined\n\nThe error appears to have been in '/root/openshift-ansible/playbooks/init/basic_facts.yml': line 116, column 5, but may\nbe elsewhere in the file depending on the exact syntax problem.\n\nThe offending line appears to be:\n\n\n  - set_fact:\n    ^ here\n\nexception type: <class 'ansible.errors.AnsibleUndefinedVariable'>\nexception: {{ (openshift_is_atomic | bool) | ternary('/usr/local/bin/oc', 'oc') }}: 'openshift_is_atomic' is undefined"
}


Version-Release number of the following components:
rpm -q openshift-ansible (latest from openshift ansible 49bacbd696f1c84eff0450dfb67693050b71b5f9)

rpm -q ansible
ansible-2.4.4.0-1.el7ae.noarch

ansible --version
ansible 2.4.4.0
  config file = /root/openshift-ansible/ansible.cfg
  configured module search path = [u'/root/.ansible/plugins/modules', u'/usr/share/ansible/plugins/modules']
  ansible python module location = /usr/lib/python2.7/site-packages/ansible
  executable location = /usr/bin/ansible
  python version = 2.7.5 (default, May  4 2018, 09:38:16) [GCC 4.8.5 20150623 (Red Hat 4.8.5-34)]

Steps to Reproduce:
1. create a cluster with 1 master
2. try to add 2 more masters with attached inventory
 ansible-playbook -i inv openshift-ansible/playbooks/openshift-master/scaleup.yml -vvv

Actual results:
scaleup fails

Expected results:
should be able to add 2 more masters

Additional info:
Please attach logs from ansible-playbook with the -vvv flag

Comment 2 Vikas Laad 2018-05-22 15:53:33 UTC
Created attachment 1440253 [details]
ansible log with -vvv

Comment 3 Michael Gugino 2018-05-23 13:45:54 UTC
PR Created in master: https://github.com/openshift/openshift-ansible/pull/8501

We should probably backport this fix to 3.9.

Comment 4 Scott Dodson 2018-05-24 13:16:46 UTC
In openshift-ansible-3.10.0-0.51.0

Comment 5 Vikas Laad 2018-05-24 15:17:22 UTC
master scaleup completed fine with latest from openshift-ansible

d0c4e258276e316d26d7322c4064df5b915f8fd6

Comment 7 errata-xmlrpc 2018-07-30 19:16:14 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:1816


Note You need to log in before you can comment on or make changes to this bug.