Bug 1581538 - Failed to create event error appears in sdn log
Summary: Failed to create event error appears in sdn log
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Networking
Version: 3.10.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 3.10.0
Assignee: Dan Winship
QA Contact: Meng Bo
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-23 03:30 UTC by Meng Bo
Modified: 2018-12-29 02:52 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
undefined
Clone Of:
Environment:
Last Closed: 2018-07-30 19:16:14 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:1816 None None None 2018-07-30 19:16:51 UTC
Origin (Github) 19818 None None None 2018-05-23 13:45:31 UTC

Description Meng Bo 2018-05-23 03:30:50 UTC
Description of problem:
Setup OCP cluster, check the sdn log after installation, there is error about failed to create event.

E0523 02:11:40.348280    9116 event.go:200] Server rejected event '&v1.Event{TypeMeta:v1.TypeMeta{Kind:"", APIVersion:""}, ObjectMeta:v1.ObjectMeta{Name:"ip-172-18-13-135.ec2.internal.1531242769331b9f", GenerateName:"", Namespace:"default", SelfLink:"", UID:"", ResourceVersion:"", Generation:0, CreationTimestamp:v1.Time{Time:time.Time{wall:0x0, ext:0, loc:(*time.Location)(nil)}}, DeletionTimestamp:(*v1.Time)(nil), DeletionGracePeriodSeconds:(*int64)(nil), Labels:map[string]string(nil), Annotations:map[string]string(nil), OwnerReferences:[]v1.OwnerReference(nil), Initializers:(*v1.Initializers)(nil), Finalizers:[]string(nil), ClusterName:""}, InvolvedObject:v1.ObjectReference{Kind:"Node", Namespace:"", Name:"ip-172-18-13-135.ec2.internal", UID:"", APIVersion:"", ResourceVersion:"", FieldPath:""}, Reason:"Starting", Message:"Starting openshift-sdn.", Source:v1.EventSource{Component:"openshift-sdn", Host:"ip-172-18-13-135.ec2.internal"}, FirstTimestamp:v1.Time{Time:time.Time{wall:0xbeb95157146b839f, ext:554092963, loc:(*time.Location)(0xaed80a0)}}, LastTimestamp:v1.Time{Time:time.Time{wall:0xbeb95157146b839f, ext:554092963, loc:(*time.Location)(0xaed80a0)}}, Count:1, Type:"Normal", EventTime:v1.MicroTime{Time:time.Time{wall:0x0, ext:0, loc:(*time.Location)(nil)}}, Series:(*v1.EventSeries)(nil), Action:"", Related:(*v1.ObjectReference)(nil), ReportingController:"", ReportingInstance:""}': 'events is forbidden: User "system:serviceaccount:openshift-sdn:sdn" cannot create events in the namespace "default": User "system:serviceaccount:openshift-sdn:sdn" cannot create events in project "default"' (will not retry!)


Version-Release number of selected component (if applicable):
v3.10.0-0.50.0
ose-node:v3.10               58027d498eba

How reproducible:
always

Steps to Reproduce:
1. Setup OCP cluster
2. Check the log in sdn pod
# oc logs sdn-57gqf -n openshift-sdn | grep event.go
3.

Actual results:
Error about failed to create event appears.

Expected results:
Should not have such error.

Additional info:

Comment 1 Dan Winship 2018-05-23 13:45:31 UTC
https://github.com/openshift/origin/pull/19818

Comment 4 Meng Bo 2018-06-06 02:30:33 UTC
Checked on v3.10.0-0.58.0, the issue has been fixed.

There is no error in the log, and the sdn related events are created under openshift-sdn project.

Comment 6 errata-xmlrpc 2018-07-30 19:16:14 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:1816


Note You need to log in before you can comment on or make changes to this bug.