Bug 1581584 - Should not log the socat cniserver.sock error to sdn pod log
Summary: Should not log the socat cniserver.sock error to sdn pod log
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Networking
Version: 3.10.0
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: ---
: 4.1.0
Assignee: Ricardo Carrillo Cruz
QA Contact: Meng Bo
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-23 07:15 UTC by Meng Bo
Modified: 2019-06-04 10:40 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-04 10:40:21 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:40:28 UTC

Description Meng Bo 2018-05-23 07:15:57 UTC
Description of problem:
Before the network started, there is script to check that if the cniserver.sock exists.
https://github.com/openshift/openshift-ansible/blob/master/roles/openshift_sdn/files/sdn.yaml#L51

And it will result that the first line of the sdn log shows the socat error which is confusing:

# oc logs sdn-57gqf -n openshift-sdn | head -10
2018/05/23 02:11:24 socat[9132] E connect(5, AF=1 "/var/run/openshift-sdn/cni-server.sock", 40): No such file or directory
warning: Cannot find existing node-config.yaml, waiting 15s ...
User "sa" set.
Context "default-context" modified.
I0523 02:11:39.977795    9116 start_node.go:304] Reading node configuration from /etc/origin/node/node-config.yaml
I0523 02:11:39.979931    9116 feature_gate.go:190] feature gates: map[RotateKubeletClientCertificate:true RotateKubeletServerCertificate:true]
I0523 02:11:39.980085    9116 start_node.go:454] Starting node networking ip-172-18-13-135.ec2.internal (v3.10.0-0.50.0)
W0523 02:11:39.980320    9116 server.go:195] WARNING: all flags other than --config, --write-config-to, and --cleanup are deprecated. Please begin using a config file ASAP.
I0523 02:11:39.980372    9116 feature_gate.go:226] feature gates: &{{} map[RotateKubeletClientCertificate:true RotateKubeletServerCertificate:true]}
I0523 02:11:39.981622    9116 transport.go:160] Refreshing client certificate from store



Version-Release number of selected component (if applicable):
v3.10.0-0.50.0
ose-node:v3.10               58027d498eba

How reproducible:
always

Steps to Reproduce:
1. Setup ocp cluster
2. Check the first lines of the sdn pod log
3.

Actual results:
It prints the confusing socat error to the sdn log.

Expected results:
Should redirect the stderr to /dev/null to avoid confusing.

Additional info:

Comment 1 Ricardo Carrillo Cruz 2019-04-05 12:34:16 UTC
https://github.com/openshift/cluster-network-operator/pull/141

Comment 3 Meng Bo 2019-04-11 07:23:45 UTC
Issue has been fixed on 4.0.0-0.nightly-2019-04-10-182914

# oc logs sdn-7c5bm | head -10
I0411 06:37:33.793192   41886 cmd.go:230] Overriding kubernetes api to https://api.qe-bmeng-ap-411.qe.devcluster.openshift.com:6443
I0411 06:37:33.793295   41886 cmd.go:133] Reading node configuration from /config/sdn-config.yaml
W0411 06:37:33.795951   41886 server.go:198] WARNING: all flags other than --config, --write-config-to, and --cleanup are deprecated. Please begin using a config file ASAP.
I0411 06:37:33.796043   41886 feature_gate.go:206] feature gates: &{map[]}
I0411 06:37:33.796112   41886 cmd.go:256] Watching config file /config/sdn-config.yaml for changes
I0411 06:37:33.796161   41886 cmd.go:256] Watching config file /config/..2019_04_11_06_36_34.899951360/sdn-config.yaml for changes
I0411 06:37:33.798980   41886 node.go:148] Initializing SDN node of type "redhat/openshift-ovs-networkpolicy" with configured hostname "ip-10-0-149-3.ap-northeast-1.compute.internal" (IP ""), iptables sync period "30s"
I0411 06:37:33.803628   41886 cmd.go:197] Starting node networking (v4.1.0-201904101232+1717772-dirty)
I0411 06:37:33.803646   41886 node.go:267] Starting openshift-sdn network plugin
I0411 06:37:33.862413   41886 healthcheck.go:29] waiting for OVS to start: dial unix /var/run/openvswitch/db.sock: connect: connection refused

Comment 5 errata-xmlrpc 2019-06-04 10:40:21 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.