Bug 158210 - nscd crashes in libnss_ldap.so.2
nscd crashes in libnss_ldap.so.2
Status: CLOSED DUPLICATE of bug 156582
Product: Fedora
Classification: Fedora
Component: nss_ldap (Show other bugs)
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Nalin Dahyabhai
: 158211 (view as bug list)
Depends On:
  Show dependency treegraph
Reported: 2005-05-19 12:29 EDT by James Bourne
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-05-23 18:35:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description James Bourne 2005-05-19 12:29:21 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050513 Fedora/1.0.4-1.3.1 Firefox/1.0.4

Description of problem:
I'm finding this is caused ONLY when ssl is set to start_tls.  If ssl is set to
on, authentication fails to work and turning off ssl fixes the problem.  Backtrace is here:

#0  0x00376f1e in ber_sockbuf_ctrl () from /lib/libnss_ldap.so.2
(gdb) bt
#0  0x00376f1e in ber_sockbuf_ctrl () from /lib/libnss_ldap.so.2
#1  0x0036bc1a in ldap_pvt_tls_inplace () from /lib/libnss_ldap.so.2
#2  0x0036d917 in ldap_start_tls_s () from /lib/libnss_ldap.so.2
#3  0x00347e3d in do_open () at ldap-nss.c:1273
#4  0x00348025 in do_init2 () at ldap-nss.c:959
#5  0x0034a8b5 in _nss_ldap_initgroups_dyn (
    user=0x3 <Address 0x3 out of bounds>, group=3, start=0x3, size=0x3, 
    groupsp=0x3, limit=3, errnop=0x3) at ldap-grp.c:912
#6  0x0028fbe4 in internal_getgrouplist (user=0x8d38cc8 "nscd", group=28, 
    size=0xbfac5b80, groupsp=0xbfac5b84, limit=-1) at initgroups.c:104
#7  0x0028fde1 in getgrouplist (user=0x8d38cc8 "nscd", group=28, groups=0x3, 
    ngroups=0xca1344) at initgroups.c:158
#8  0x00c91aed in nscd_init () at connections.c:1598
#9  0x00c910ad in main (argc=1, argv=0xbfac5ef4) at nscd.c:286

Version-Release number of selected component (if applicable):
nss_ldap-234-2 and glibc-2.3.5-6

How reproducible:

Steps to Reproduce:
1. set ssl to start_tls in /etc/ldap.conf
2. restart nscd

Actual Results:  nscd crashes and authentication fails

Expected Results:  nscd should start and cache authentication information.

Additional info:

From bug number 155124

Comment #5 From Jakub Jelinek (jakub@redhat.com)  	 on 2005-05-19 12:15 EST  	[reply]  	   	 

Crash in /lib/libnss_ldap.so.2 is almost surely a bug in nss_ldap (until proven
otherwise), so please file that separately, under nss_ldap component.
Comment 1 James Bourne 2005-05-19 12:32:13 EDT
*** Bug 158211 has been marked as a duplicate of this bug. ***
Comment 2 Jeremy Katz 2005-05-23 18:35:01 EDT

*** This bug has been marked as a duplicate of 156582 ***

Note You need to log in before you can comment on or make changes to this bug.