Bug 1582155 - sudo blocks in poll() for /dev/ptmx with iolog enabled [rhel-7.5.z]
Summary: sudo blocks in poll() for /dev/ptmx with iolog enabled [rhel-7.5.z]
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: sudo
Version: 7.4
Hardware: Unspecified
OS: Linux
urgent
high
Target Milestone: rc
: ---
Assignee: Daniel Kopeček
QA Contact: Dalibor Pospíšil
URL:
Whiteboard:
Keywords: Patch, Regression, Reproducer, Triaged, ZStream
Depends On: 1560657
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-24 11:54 UTC by Oneata Mircea Teodor
Modified: 2018-06-26 16:52 UTC (History)
5 users (show)

(edit)
Previously, when running a command through sudo that had the I/O logging enabled, a parent process of the command was occasionally blocked in the poll() function execution, waiting for an event on the /dev/ptmx file descriptor. Consequently, a deadlock occurred and sudo might leave the process of the command in an unresponsive state. This update adds a pseudoterminal cleanup logic, and sudo no longer causes a deadlock in the described scenario.
Clone Of: 1560657
(edit)
Last Closed: 2018-06-26 16:52:30 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:1992 None None None 2018-06-26 16:52 UTC
Red Hat Knowledge Base (Solution) 3404401 None None None 2018-05-24 11:54 UTC

Description Oneata Mircea Teodor 2018-05-24 11:54:20 UTC
This bug has been copied from bug #1560657 and has been proposed to be backported to 7.5 z-stream (EUS).

Comment 7 errata-xmlrpc 2018-06-26 16:52:30 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:1992


Note You need to log in before you can comment on or make changes to this bug.