Bug 158218 - confusing message/choice when sector size != 512 bytes detected
Summary: confusing message/choice when sector size != 512 bytes detected
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: parted   
(Show other bugs)
Version: 4.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: David Cantrell
QA Contact: Brock Organ
URL:
Whiteboard: RHEL4U3NAK
Keywords: Translation
Depends On:
Blocks: 181409
TreeView+ depends on / blocked
 
Reported: 2005-05-19 17:33 UTC by David Lehman
Modified: 2013-01-10 21:42 UTC (History)
6 users (show)

Fixed In Version: RHBA-2006-0384
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-10 21:27:11 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
parted exception message rewording (728 bytes, patch)
2006-04-13 17:31 UTC, David Cantrell
no flags Details | Diff
updated translations for new message string (175.59 KB, patch)
2006-04-28 21:28 UTC, Paul Gampe
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2006:0384 normal SHIPPED_LIVE parted bug fix update 2006-08-09 04:00:00 UTC

Description David Lehman 2005-05-19 17:33:28 UTC
Description of problem:
If you run parted on a disk whose sector size is not 512 bytes it presents a
warning as follows:

    The sector size on /dev/sdb is 4096 bytes.  Parted is known not to work
    properlywith drives with sector sizes other than 512 bytes
    Ignore/Cancel?

As it turns out, "Cancel" in this case means "pretend the disk has 512 bytes
sectors" whereas "Ignore" means "ignore the warning and proceed with 4096 byte
sectors". This is highly confusing to any who have not read the code. Most
confusing is the fact that entering "cancel" at this prompt does not cause
parted to exit.

Version-Release number of selected component (if applicable):
parted-1.6.19-1.EL

How reproducible:
Always

Steps to Reproduce:
1. Run parted on a disk whose sector size is not 512 bytes (eg a huge SCSI disk)
2. Type "cancel" when presented with the above message
3.
  
Actual results:
Parted appears to continue as though you selected "ignore". It makes no mention
before or after of the fact that you are choosing sector sizes, not whether or
not to continue at all.

Expected results:
A clear message that asks the user a) whether or not to continue at all and, if
so, b) whether to use the detected sector size or parted's default (512 bytes).

Additional info:

Comment 9 David Cantrell 2006-04-11 15:19:07 UTC
I can reword the exception handler to present a yes/no question for this
situation.  If I add text to the message, it will need to be translated to the
other languages.

I can fix this for RHEL4U4.

Comment 10 David Cantrell 2006-04-13 17:31:29 UTC
Created attachment 127716 [details]
parted exception message rewording

Here's the patch I'm proposing.  I changed it to ask a yes/no question and
added the sentence "Use NNN sector size?"

Comment 11 David Cantrell 2006-04-13 17:32:51 UTC
mkim:  Is translation for this patch possible for RHEL4U4?

Comment 12 Michelle Kim 2006-04-17 02:50:42 UTC
Sure David, 
Is it okay if I provide translation for the following particular sentence in
text format?

The sector size on %s is %d bytes.  Parted is known not to work properly with
drives with sector sizes other than %d bytes.  Use %d sector size?"

Once I gather translation from each translator, I will attach the translation
back to this ticket.

Cheers,
Michelle


Comment 13 David Cantrell 2006-04-17 17:34:20 UTC
Michelle,

That will be fine.  I can add the translations to the patch for the package. 
I've committed to April 28th for early release errata for this package.  Can you
get the translations to me before then?

Thanks,
David

Comment 14 David Cantrell 2006-04-26 15:39:13 UTC
Still waiting on translations for this update.

Comment 15 Michelle Kim 2006-04-28 01:00:45 UTC
Hi David,

Thanks for waiting. Please find the attached translations for 14 supported 
langs from translation team in Brisbane:

English: The sector size on %s is %d bytes.  Parted is known not to work 
properly
with drives with sector sizes other than %d bytes.  Use %d sector size?"

Korean: %s ì ì¹í° ì©ëì %d ë°ì´í¸ìëë¤. Partedë ì¹í° ì©ëì´ %d ë°ì´í¸ ë³´ë¤ í´ ê²½ì° 
ëë¼ì´ë¸ë¥¼ ì ëë¡ íí°ìíì§ ëª»í©ëë¤. ì¹í° ì©ëì %dì¼ë¡ íìê² ìµëê¹?

German: Die SektorgröÃe auf %s ist %d Bytes.  Parted ist dafür bekannt nicht 
einwandfrei mit Laufwerken zu arbeiten, die eine SektorgröÃe ungleich %d Bytes 
verwenden.  %d Bytes SektorgröÃe verwenden?

Punjabi: %s à¨à©±à¨ªà¨° ਸà©à¨à¨à¨° à¨à¨à¨¾à¨° %d ਬਾà¨à¨ ਹà©à¥¤ ਵਿਭਾà¨à¨¨ à¨à©à¨¤à© ਬਾਰ੠à¨à¨¾à¨£à¨à¨¾à¨°à© ਹ੠à¨à¨¿ %d ਬਾà¨à¨ ਤà©à¨ ਵੱà¨à¨°à© 
ਸà©à¨à¨à¨° à¨à¨à¨¾à¨° ਵਾਲà©à¨à¨ ਡਰਾà¨à¨µà¨¾à¨ ਨਾਲ ਠà©à¨ ਤਰਾਠà¨à©°à¨® ਨਹà©à¨ à¨à¨°à¨¦à¨¾à¥¤ %d ਸà©à¨à¨à¨° à¨à¨à¨¾à¨° ਵਰਤà©?

Bengali: %s'র à¦à¦ªà¦° সà§à¦à§à¦à¦°à§à¦° মাপ হল %d বাà¦à¦à¥¤ %d বাà¦à¦ বà§à¦¯à¦¾à¦¤à§à¦¤ à¦à¦¨à§à¦¯à¦¾à¦¨à§à¦¯ মাপà§à¦° সà§à¦à§à¦à¦°à§à¦° সাথৠparted 
à¦à§à¦à¦¾à¦¨à¦¤ à¦à¦²à¦¤à§ সà¦à§à¦·à¦® নà§à¥¤ পরিবরà§à¦¤à§ %d মাপà§à¦° সà§à¦à§à¦à¦° পà§à¦°à§à§à¦ à¦à¦°à¦¾ হবৠà¦à¦¿?

Hindi: %s पर सà¥à¤à¥à¤à¤° à¤à¤à¤¾à¤° %d बाà¤à¤ à¤à¤¾ हà¥.  विभाà¤à¤¿à¤¤ à¤à¤¿à¤¯à¤¾ हà¥à¤ %d बाà¤à¤ à¤à¥ à¤à¤²à¤¾à¤µà¥ सà¥à¤à¥à¤à¤° à¤à¤à¤¾à¤° à¤à¥ 
डà¥à¤°à¤¾à¤à¤µ à¤à¥ साथ ठà¥à¤ सॠà¤à¤¾à¤® à¤à¤°à¤¤à¤¾ हà¥à¤ नहà¥à¤ पà¥à¤°à¤¤à¥à¤¤ हà¥à¤¤à¤¾ हà¥.  %d सà¥à¤à¥à¤à¤° à¤à¤à¤¾à¤° à¤à¤¾ पà¥à¤°à¤¯à¥à¤ à¤à¤°à¥à¤?

Gujarati: %s પરનà«àª સà«àªà«àªàª° માપ ઠ%d બાàªàªà« àªà«. Parted ઠ%d બાàªàªà« સિવાયના àªàª¨à«àª¯ માપ સાથà«àª¨à« 
ડà«àª°àª¾àªàªµà« સાથૠયà«àªà«àª¯ રà«àª¤à« àªàª¾àª® નહિઠàªàª°àªµàª¾ માàªà« àªàª¾àª£à«àª¤à«àª àªà«. શà«àª %d સà«àªà«àªàª° માપ વાપરવà«àª àªà«?

Tamil: %s ன௠வà®à¯à®à®à¯à®à¯à®±à¯ à®à®³à®µà¯ %d பà¯à®à¯à®à¯à®à®³à¯ à®à®à¯à®®à¯. பிரிà®à¯à®à®ªà¯à®ªà®à¯à®à®¤à¯ à®à®¯à®à¯à®à®¿à®à®³à¯à®à®©à¯ 
%d பà¯à®à¯ 
வà®à¯à®à®à¯à®à¯à®±à¯ à®à®³à®µà¯à®à®³à®¿à®²à¯ à®à®°à®¿à®¯à®¾à® பணி à®à¯à®¯à¯à®¯à®µà®¿à®²à¯à®²à¯. %d வà®à¯à®à®à¯à®à¯à®±à¯ à®à®³à®µà®¿à®©à¯ 
பயனà¯à®ªà®à¯à®¤à¯à®¤ 
வà¯à®£à¯à®à¯à®®à®¾?

Japanese: %s ä¸ã®ã»ã¯ã¿ã¼ãµã¤ãºã¯ %d ãã¤ãã§ããParted 㯠%d ãã¤ã以å¤ã®ã»ã¯ã¿ã¼ãµã¤
ãºã®ãã©ã¤ãã§ã¯æ­£ããåä½ããªããã¨ã
ç¥ããã¦ãã¾ãã%d ã®ã»ã¯ã¿ã¼ãµã¤ãºã使ç¨ãã¾ãã?

French: La taille du secteur sur %s est %d octets. Parted ne fonctionne pas 
correctement avec des pilotes de taille de secteur différente de %d 
octets. Souhaitez-vous utiliser une taille de secteur de %d ?

Spanish: El tamaño de sector en %s es de %d bytes. Se sabe que Parted no 
trabaja
apropiadamente con dispositivos que tienen un tamaño de sector diferente
a %d bytes. ¿Utilizar tamaño de sector de %d?

Italian: La dimensione del settore su %s è di %d byte. Parted non funziona
correttamente se utilizzato con drive con dimensioni del settore diverse
da %d byte. Utilizzare %d come dimensione del settore?

Traditional Chinese: %s ä¸çç£å大å°æ¯ %d ä½åçµãParted åªè½å¨ç£å大å°çº %d ä½åçµç
硬ç¢ä¸éä½ãæ¨è¦ä½¿ç¨ %d ç£å大å°åï¼

Simplified Chinese: å¨ %s ä¸çæåºç大å°æ¯ %d å­èãParted æ æ³å¨æåºå¤§äº %d å­èç驱
å¨å¨ä¸æ­£å¸¸å·¥ä½ã使ç¨å¤§å°ä¸º %d çæåºï¼

Russian: Ð Ð°Ð·Ð¼ÐµÑ ÑекÑоÑа диÑка %s Ñавен %d байÑ. Parted ÑабоÑÐ°ÐµÑ Ð½ÐµÐºÐ¾ÑÑекÑно 
Ñ Ð´Ð¸Ñками, ÑÐ°Ð·Ð¼ÐµÑ ÑекÑоÑов коÑоÑÑÑ Ð¾ÑлиÑен Ð¾Ñ %d байÑ. 
ÐÑполÑзоваÑÑ ÑÐ°Ð·Ð¼ÐµÑ ÑекÑоÑа ÑавнÑй %d?


If you require further assitance, please let me know.

Regards,
Michelle Kim





Comment 16 David Cantrell 2006-04-28 15:25:01 UTC
(In reply to comment #15)
> Hi David,
> 
> Thanks for waiting. Please find the attached translations for 14 supported 
> langs from translation team in Brisbane:

Michelle,

Thanks for sending those.  I'm having trouble adding the translations to the po
files (mostly it's because I don't know how to deal with these character sets
and I'm trying various copy and paste methods from the browser).

Could you attach the translated text as a separate file that I can download?

Thanks,

David


Comment 17 Paul Gampe 2006-04-28 21:28:50 UTC
Created attachment 128378 [details]
updated translations for new message string

Dave, parted-16.19/po/ directory only has a subset of our Red Hat Tier-1
languages. That being {de,es,fr,it,ja,ru,zh_CN}.po. Please find a patch against
this language set attached.

I applied your previous patch and updated the parted.pot so you can get the
exact msgid/msgstr you are looking for. You may notice that these patches
pickup other changes you may not need so feel free to pick and choose.

I've double checked the file encodings for the patch set should be correct.
Please note that the parted .po files have not yet been converted to UTF-8
though so let me know if that causes you any problems.

Comment 18 David Cantrell 2006-05-01 15:32:19 UTC
I've added the translations and built a new package.  Thanks for the patch, Paul.

Comment 23 Red Hat Bugzilla 2006-08-10 21:27:16 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2006-0384.html



Note You need to log in before you can comment on or make changes to this bug.