Bug 1582230 - etcd scaleup failed - 'dict object' has no attribute 'etcd_ip'
Summary: etcd scaleup failed - 'dict object' has no attribute 'etcd_ip'
Keywords:
Status: CLOSED DUPLICATE of bug 1578482
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 3.10.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: ---
Assignee: Scott Dodson
QA Contact: Johnny Liu
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-24 15:21 UTC by Vikas Laad
Modified: 2018-05-24 19:04 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-24 19:04:01 UTC
Target Upstream Version:


Attachments (Terms of Use)
ansible log with -vvv (3.82 MB, text/plain)
2018-05-24 15:23 UTC, Vikas Laad
no flags Details

Description Vikas Laad 2018-05-24 15:21:03 UTC
Description of problem:
Scaleup of etcd failed when scaling up etcd from 1 to 3 nodes.

Version-Release number of the following components:
openshift-ansible - d0c4e258276e316d26d7322c4064df5b915f8fd6

rpm -q ansible
ansible-2.4.4.0-1.el7ae.noarch

ansible --version
ansible 2.4.4.0
  config file = /etc/ansible/ansible.cfg
  configured module search path = [u'/root/.ansible/plugins/modules', u'/usr/share/ansible/plugins/modules']
  ansible python module location = /usr/lib/python2.7/site-packages/ansible
  executable location = /usr/bin/ansible
  python version = 2.7.5 (default, May  4 2018, 09:38:16) [GCC 4.8.5 20150623 (Red Hat 4.8.5-34)]

Steps to Reproduce:
1. create 1 node etcd cluster
2. try to add 2 more nodes to etcd my running playbook openshift-ansible/playbooks/openshift-etcd/scaleup.yml

Actual results:
Please include the entire output from the last TASK line through the end of output if an error is generated

Expected results:
playbook fails

Additional info:
Please attach logs from ansible-playbook with the -vvv flag

Comment 2 Vikas Laad 2018-05-24 15:23:46 UTC
Created attachment 1441098 [details]
ansible log with -vvv

Comment 3 Vikas Laad 2018-05-24 19:04:01 UTC

*** This bug has been marked as a duplicate of bug 1578482 ***


Note You need to log in before you can comment on or make changes to this bug.