Bug 1582400 - Add new devices failed per local volume doc
Summary: Add new devices failed per local volume doc
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Storage
Version: 3.10.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 3.10.0
Assignee: Jan Safranek
QA Contact: Qin Ping
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-25 06:34 UTC by Qin Ping
Modified: 2018-07-30 19:16 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
undefined
Clone Of:
Environment:
Last Closed: 2018-07-30 19:16:18 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:1816 None None None 2018-07-30 19:16:38 UTC

Description Qin Ping 2018-05-25 06:34:14 UTC
Description of problem:
Add new devices failed per local volume doc

Version-Release number of selected component (if applicable):
oc v3.10.0-0.51.0
kubernetes v1.10.0+b81c8f8
openshift v3.10.0-0.51.0

How reproducible:
Always

Steps to Reproduce:
https://github.com/openshift/openshift-docs/blob/master/install_config/configuring_local.adoc#local-volume-adding-new-devices

Actual results:
Add devices according the "Adding New Devices" part, no PV was created and got log:
E0525 06:25:20.967925       1 discovery.go:201] Path "/mnt/local-storage/ssd/dis1" is not an actual mountpoint

# df /mnt/local-storage/ssd/dis1
Filesystem     1K-blocks  Used Available Use% Mounted on
vol5             1940472     0   1940472   0% /mnt/local-storage/ssd/dis1


Expected results:
Add new device successfully.

Master Log:

Node Log (of failed PODs):

PV Dump:

PVC Dump:

StorageClass Dump (if StorageClass used by PV/PVC):

Additional info:

Comment 1 Jan Safranek 2018-05-25 12:50:53 UTC
The template probably needs mountPropagation enabled.

Comment 2 Jan Safranek 2018-05-25 12:59:16 UTC
Origin PR: https://github.com/openshift/origin/pull/19845

Comment 5 Qin Ping 2018-06-05 09:55:21 UTC
Verified in openshift:
oc v3.10.0-0.58.0
openshift v3.10.0-0.58.0
kubernetes v1.10.0+b81c8f8

# cat /etc/redhat-release 
Red Hat Enterprise Linux Server release 7.5 (Maipo)

# uname -a
Linux qe-piqin-master-etcd-nfs-1 3.10.0-862.3.2.el7.x86_64 #1 SMP Tue May 15 18:22:15 EDT 2018 x86_64 x86_64 x86_64 GNU/Linux

Comment 7 errata-xmlrpc 2018-07-30 19:16:18 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:1816


Note You need to log in before you can comment on or make changes to this bug.