Bug 1582484 - [RFE] As an API user, I should be able to compare the Errata of a Content View Version to the installable Errata in Library.
Summary: [RFE] As an API user, I should be able to compare the Errata of a Content Vie...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Content Management
Version: 6.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: Released
Assignee: Lai
QA Contact: Lai
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-25 11:51 UTC by pm-sat@redhat.com
Modified: 2019-10-07 17:17 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-05-14 12:37:23 UTC


Attachments (Terms of Use)
Errata comparison (5.17 KB, text/plain)
2018-12-14 17:24 UTC, Lai
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHSA-2019:1222 None None None 2019-05-14 12:37:30 UTC
Foreman Issue Tracker 23318 None None None 2018-05-25 11:51:47 UTC

Description pm-sat@redhat.com 2018-05-25 11:51:46 UTC
The Errata of a Content View Version can currently be compared to the Errata in Library using /katello/api/content_view_versions/:id/available_errata.

However, this API endpoint only supports filtering by applicable Errata.  It does not currently support filtering by installable Errata.

Comment 1 pm-sat@redhat.com 2018-05-25 11:51:50 UTC
Created from redmine issue http://projects.theforeman.org/issues/23318

Comment 2 pm-sat@redhat.com 2018-05-25 11:51:53 UTC
Upstream bug assigned to None

Comment 4 pm-sat@redhat.com 2018-05-25 12:03:07 UTC
Moving this bug to POST for triage into Satellite 6 since the upstream issue http://projects.theforeman.org/issues/23318 has been resolved.

Comment 7 Lai 2018-12-14 17:24:12 UTC
Created attachment 1514428 [details]
Errata comparison

Steps to verify:

1. Set up a content view
2. Add repo and sync repo
3. publish new version
4. Filter dates to something in the past
5. publish new version
6. GET /katello/api/v2/errata/compare/?content_view_version_ids[]=15&content_view_version_ids[]=14

Verify the comparisons between different versions.  Attached is a snippet of an errata that is in 14, 15, and both 14 and 15.

Verified on 6.5.0 snap 7.0

Comment 10 errata-xmlrpc 2019-05-14 12:37:23 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHSA-2019:1222


Note You need to log in before you can comment on or make changes to this bug.