Bug 1582489 - Memory leak, at least 7.31 KB per minute
Summary: Memory leak, at least 7.31 KB per minute
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-hosted-engine-ha
Classification: oVirt
Component: Agent
Version: 2.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ovirt-4.2.4
: 2.2.13
Assignee: Andrej Krejcir
QA Contact: Nikolai Sednev
URL:
Whiteboard:
Depends On:
Blocks: ovirt-hosted-engine-ha-2.2.14
TreeView+ depends on / blocked
 
Reported: 2018-05-25 12:01 UTC by Andrej Krejcir
Modified: 2018-06-26 08:36 UTC (History)
3 users (show)

Fixed In Version: ovirt-hosted-engine-ha-2.2.13-1.el7ev
Doc Type: No Doc Update
Doc Text:
undefined
Clone Of:
Environment:
Last Closed: 2018-06-26 08:36:45 UTC
oVirt Team: SLA
rule-engine: ovirt-4.2+


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 91737 0 master MERGED Add memory profiler to track memory leaks 2020-09-10 01:06:53 UTC
oVirt gerrit 91738 0 master MERGED Use single instance of the intermittent logging filter 2020-09-10 01:06:53 UTC
oVirt gerrit 91790 0 v2.2.z MERGED Add memory profiler to track memory leaks 2020-09-10 01:06:53 UTC
oVirt gerrit 91791 0 v2.2.z MERGED Use single instance of the intermittent logging filter 2020-09-10 01:06:53 UTC

Description Andrej Krejcir 2018-05-25 12:01:55 UTC
Description of problem:
There is a memory leak of at least 7.31 KB per minute, which is 10.27 MB per day.

It can be worse. On one of our deployments, the agent has been running for 43 days and consumes 1153 MB of memory.

Version:
ovirt-hosted-engine-ha-2.3.0-0.0.master.git308874a

Comment 1 Yaniv Kaul 2018-05-27 06:24:39 UTC
Severity?

Comment 2 Nikolai Sednev 2018-06-06 07:06:12 UTC
Not being reproduced on these components:
ovirt-hosted-engine-ha-2.2.13-1.el7ev.noarch
ovirt-hosted-engine-setup-2.2.22-1.el7ev.noarch
rhvm-appliance-4.2-20180601.0.el7.noarch
Linux 3.10.0-862.3.2.el7.x86_64 #1 SMP Tue May 15 18:22:15 EDT 2018 x86_64 x86_64 x86_64 GNU/Linux
Red Hat Enterprise Linux Server release 7.5 (Maipo)

alma03 ~]# ps --sort -rss -eo pid,pmem,rss,vsz,comm | head -16 | grep ovirt-ha-agent
 78586  0.1 33060 458404 ovirt-ha-agent
alma03 ~]# ps -o rss,sz,vsz 78586
  RSS    SZ    VSZ
33060 114601 458404

alma04 ~]# ps --sort -rss -eo pid,pmem,rss,vsz,comm | head -16 | grep ovirt-ha-agent
 52030  0.1 33076 458404 ovirt-ha-agent
[root@alma04 ~]# ps -o rss,sz,vsz 78586
  RSS    SZ    VSZ
alma04 ~]# hosted-engine --vm-status


--== Host 1 status ==--

conf_on_shared_storage             : True
Status up-to-date                  : True
Hostname                           : alma04
Host ID                            : 1
Engine status                      : {"reason": "vm not running on this host", "health": "bad", "vm": "down", "detail": "unknown"}
Score                              : 3400
stopped                            : False
Local maintenance                  : False
crc32                              : e1e28674
local_conf_timestamp               : 70519
Host timestamp                     : 70519
Extra metadata (valid at timestamp):
        metadata_parse_version=1
        metadata_feature_version=1
        timestamp=70519 (Wed Jun  6 09:40:27 2018)
        host-id=1
        score=3400
        vm_conf_refresh_time=70519 (Wed Jun  6 09:40:27 2018)
        conf_on_shared_storage=True
        maintenance=False
        state=EngineDown
        stopped=False


--== Host 2 status ==--

conf_on_shared_storage             : True
Status up-to-date                  : True
Hostname                           : alma03
Host ID                            : 2
Engine status                      : {"health": "good", "vm": "up", "detail": "Up"}
Score                              : 3400
stopped                            : False
Local maintenance                  : False
crc32                              : f0abfe82
local_conf_timestamp               : 68707
Host timestamp                     : 68707
Extra metadata (valid at timestamp):
        metadata_parse_version=1
        metadata_feature_version=1
        timestamp=68707 (Wed Jun  6 09:40:22 2018)
        host-id=2
        score=3400
        vm_conf_refresh_time=68707 (Wed Jun  6 09:40:22 2018)
        conf_on_shared_storage=True
        maintenance=False
        state=EngineUp
        stopped=False

Moving to verified.
Please reopen if you still see this happening.

Comment 3 Sandro Bonazzola 2018-06-26 08:36:45 UTC
This bugzilla is included in oVirt 4.2.4 release, published on June 26th 2018.

Since the problem described in this bug report should be
resolved in oVirt 4.2.4 release, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.