Bug 1582591 - Image pull fails after upgrade - unauthorized: authentication required
Summary: Image pull fails after upgrade - unauthorized: authentication required
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 3.10.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 3.10.0
Assignee: Scott Dodson
QA Contact: Vikas Laad
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-25 17:06 UTC by Vikas Laad
Modified: 2018-07-30 19:16 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
undefined
Clone Of:
Environment:
Last Closed: 2018-07-30 19:16:18 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:1816 None None None 2018-07-30 19:16:38 UTC

Description Vikas Laad 2018-05-25 17:06:13 UTC
Description of problem:
After upgrade creating new pods fail due to following errors

  Warning  Failed          2m (x2 over 2m)  kubelet, ip-172-31-49-20.us-west-2.compute.internal  Failed to pull image "docker-registry.default.svc.cluster.local:5000/openshift/mysql@sha256:01c59852b0c720322598a5370ed93038e04af101b1e3ee55a1aab77bf600a7af": rpc error: code = Unknown desc = unauthorized: authentication required
  Warning  Failed          2m (x2 over 2m)  kubelet, ip-172-31-49-20.us-west-2.compute.internal  Error: ErrImagePull
  Normal   SandboxChanged  1m (x7 over 2m)  kubelet, ip-172-31-49-20.us-west-2.compute.internal  Pod sandbox changed, it will be killed and re-created.
  Normal   BackOff         1m (x6 over 2m)  kubelet, ip-172-31-49-20.us-west-2.compute.internal  Back-off pulling image "docker-registry.default.svc.cluster.local:5000/openshift/mysql@sha256:01c59852b0c720322598a5370ed93038e04af101b1e3ee$5a1aab77bf600a7af"


Version-Release number of the following components:
openshift-ansible - a1c263f3a9e00345f3a176702a77fea9081a4d67

rpm -q ansible
ansible-2.4.3.0-1.el7ae.noarch

ansible --version
ansible 2.4.3.0
  config file = /root/openshift-ansible/ansible.cfg
  configured module search path = [u'/root/.ansible/plugins/modules', u'/usr/share/ansible/plugins/modules']
  ansible python module location = /usr/lib/python2.7/site-packages/ansible
  executable location = /usr/bin/ansible
  python version = 2.7.5 (default, Apr 19 2018, 05:40:55) [GCC 4.8.5 20150623 (Red Hat 4.8.5-28)]

Steps to Reproduce:
1. create 3.9 cluster
2. upgrade to 3.10 cluster version openshift v3.10.0-0.52.0
3. create a new cakephp-mysql template app

Actual results:
app creation fails due to error


Expected results:
App should be created

Additional info:
Please attach logs from ansible-playbook with the -vvv flag

Comment 3 Vikas Laad 2018-06-05 19:47:37 UTC
Verified on following version

openshift v3.10.0-0.60.0

Comment 5 errata-xmlrpc 2018-07-30 19:16:18 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:1816


Note You need to log in before you can comment on or make changes to this bug.