Bug 1582631 - xscerensaver-getimage killed by SIGSEGV(backtrack is unusable)
Summary: xscerensaver-getimage killed by SIGSEGV(backtrack is unusable)
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: xscreensaver
Version: 27
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Mamoru TASAKA
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-25 19:40 UTC by jamie
Modified: 2018-07-01 02:36 UTC (History)
5 users (show)

Fixed In Version: xscreensaver-5.39-6.fc27
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-07-01 01:33:38 UTC


Attachments (Terms of Use)
ABRT email from xscreensaver crash (28.58 KB, text/plain)
2018-06-06 11:59 UTC, Steve Berg
no flags Details

Description jamie 2018-05-25 19:40:34 UTC
Description of problem:
xscerensaver-getimage crashes 


How reproducible:
Very 

Steps to Reproduce:
1. Wait for the wrong screensaver to be displayed 
2. It will crash
3.

Actual results:
Crash

Expected results:
It works 

Additional info:
Note sure the priority since I have not tested it with a lock screen.(so I don't know if people's computers could become unlocked when it crashes).

Sorry, the backtrace always ends up being unusable but this happens frequently enough that I was hoping someone can fix it just the same.

Comment 1 Mamoru TASAKA 2018-05-28 07:47:36 UTC
Well, unless useful backtrace, I cannot debug the issue because for me xscerensaver-getimage works.

BTW current debuginfo rpms seems broken - it should be fixed in xscreensaver-5.39-5.fc27 so please use it:

https://kojipkgs.fedoraproject.org/packages/xscreensaver/5.39/5.fc27/

(I won't push the above package into testing repository for now - first I will wait for that you gain backtrace information using the above)

Comment 2 jamie 2018-05-28 13:58:19 UTC
Ok, I'll let you know when it crashes again with the new package.

Comment 3 jamie 2018-05-28 14:09:02 UTC
I don't know which screensaver is causing it too crash and have a bunch of them which appear at random times.

Comment 4 Mamoru TASAKA 2018-05-28 14:18:03 UTC
Then why do you know xscreensaver-getimage is crashing?

Comment 5 jamie 2018-05-28 14:24:54 UTC
Because it generates a 'Problem Report'. As you say 'debuginfo rpms seems broken', so I can't get a good stack trace. I am installing the new version. Oh, I accidentally checked the 'I am submitting the needed info' button.

Comment 6 Mamoru TASAKA 2018-05-28 14:36:39 UTC
Then with new package (xscreensaver-5.39-5.fc27), abrt should be able to generate proper backtrace and then it should be that you can submit such report.

Comment 7 Mamoru TASAKA 2018-05-28 14:43:43 UTC
If abrt are to open a new bug report, I can mark this bug as a duplicate of such new bug ticket.

Comment 8 jamie 2018-05-28 14:50:15 UTC
Ok, I have the package, so next time it crashes, I'll submit the report via abrt.

Comment 9 jamie 2018-05-31 19:55:09 UTC
Not seeing the crash with the new RPMs. Maybe it's an issue with the old version, in which case we should probably just wait.

Comment 10 Mamoru TASAKA 2018-06-04 07:37:39 UTC
If you still fail to see this bug with -5.fc27, once I am going to close this bug.

Comment 11 jamie 2018-06-04 13:39:41 UTC
Good thinking.

Comment 12 Steve Berg 2018-06-06 11:59:32 UTC
Created attachment 1448298 [details]
ABRT email from xscreensaver crash

I'm seeing similar crashes on SciLinux systems that have xscreensaver-5.39-3 installed.

Comment 13 Mamoru TASAKA 2018-06-06 12:16:07 UTC
(In reply to Steve Berg from comment #12)
> Created attachment 1448298 [details]
> ABRT email from xscreensaver crash
> 
> I'm seeing similar crashes on SciLinux systems that have xscreensaver-5.39-3
> installed.

Unfortunately, this log is not useful.

Now once I am closing this bug. Once you can reproduce this issue with good backtrace, please file a new bug. Thank you anyway.

Comment 14 Mamoru TASAKA 2018-06-06 12:40:30 UTC
By the way, as I said in the comment 5, current xscreensaver rpm (xscreensaver-5.39-4) cannot generate backtrace properly. I've now submitted -5:

https://bodhi.fedoraproject.org/updates/FEDORA-2018-9a7432f63c
https://bodhi.fedoraproject.org/updates/FEDORA-2018-94d01495e6

so that abrt can generate backtrace properly.

Comment 15 Mamoru TASAKA 2018-06-06 12:48:58 UTC
... oops, comment 6, sorry.

Comment 16 Fedora Update System 2018-06-20 13:47:08 UTC
xscreensaver-5.39-6.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-8211027aea

Comment 17 Fedora Update System 2018-06-20 13:47:44 UTC
xscreensaver-5.39-6.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2018-efaf07442c

Comment 18 Mamoru TASAKA 2018-06-20 13:49:28 UTC
(In reply to Steve Berg from comment #12)
> Created attachment 1448298 [details]
> ABRT email from xscreensaver crash
> 
> I'm seeing similar crashes on SciLinux systems that have xscreensaver-5.39-3
> installed.

> "function_name": "minixpm_to_ximage"
> "function_name": "xscreensaver_logo"
> "function_name": "main"

Actually now I guess I've reproduced this issue, and I believe -6 should fix this issue.

Comment 19 Fedora Update System 2018-06-21 13:40:50 UTC
xscreensaver-5.39-6.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-efaf07442c

Comment 20 Fedora Update System 2018-06-21 16:13:34 UTC
xscreensaver-5.39-6.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-8211027aea

Comment 21 Fedora Update System 2018-07-01 01:33:38 UTC
xscreensaver-5.39-6.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.

Comment 22 Fedora Update System 2018-07-01 02:36:59 UTC
xscreensaver-5.39-6.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.