This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 158273 - Add init scripts to bittorrent package
Add init scripts to bittorrent package
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: bittorrent (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Paul Howarth
Fedora Extras Quality Assurance
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-05-20 03:19 EDT by Seth Vidal
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: 4.1.1-2
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-23 06:39:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
tar ball of the init scripts and sysconfig files (1.05 KB, application/octet-stream)
2005-05-20 03:19 EDT, Seth Vidal
no flags Details
new bittorrent init scripts for tracker and seed (1.12 KB, application/x-gzip)
2005-06-01 02:21 EDT, Seth Vidal
no flags Details

  None (edit)
Description Seth Vidal 2005-05-20 03:19:22 EDT
Description of problem:
Add init scripts (soon to be attached) to bittorrent package so users can easily
setup trackers and seeders on their own.

See attached.
Comment 1 Seth Vidal 2005-05-20 03:19:22 EDT
Created attachment 114617 [details]
tar ball of the init scripts and sysconfig files
Comment 2 Seth Vidal 2005-05-20 03:20:08 EDT
It'd be really spiffy if it could get a logrotate.d file, too.
Comment 3 Paul Howarth 2005-05-20 05:39:11 EDT
Do you have any sample log files for the tracker?
Comment 4 Paul Howarth 2005-05-23 06:39:56 EDT
Forget the logfile samples request - I was thinking of logwatch rather than
logrotate.

Initscripts added in bittorrent-4.0.1-2, currently in build queue.
Comment 5 Seth Vidal 2005-05-30 01:37:22 EDT
I'll be posting some new init scripts for bittorrent shortly.

the ones I posted before kinda sucked for various reasons. These are mo-betta.

Comment 6 Paul Howarth 2005-05-30 05:51:47 EDT
Glad to hear it; I noticed that btseed was causing initlog to use lots of CPU
and memory after a while, probably because it didn't daemonize properly, but I
haven't had chance to investigate yet.
Comment 7 Seth Vidal 2005-06-01 02:21:38 EDT
Created attachment 115018 [details]
new bittorrent init scripts for tracker and seed

new initscripts for the bittorrent package.
Comment 8 Paul Howarth 2005-06-03 11:48:51 EDT
I've updated the scripts in the bittorrent-4.1.1-2.fc5 package (devel). Not
quite the same as the ones you supplied; I've now managed to get them in a state
where they check properly that the "daemons" have started and also that I can
start them from an ssh session and actually be able to log out of that session
cleanly :-)
Comment 9 Seth Vidal 2005-06-03 13:45:47 EDT
yah, I noticed those checkins. That rocks. Thanks!

Note You need to log in before you can comment on or make changes to this bug.