Bug 1582826 - [UI] - When opening the setup networks dialogue it is taking few seconds to load the host interfaces
Summary: [UI] - When opening the setup networks dialogue it is taking few seconds to ...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: BLL.Network
Version: 4.2.3.5
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ovirt-4.2.4
: ---
Assignee: Ales Musil
QA Contact: Michael Burman
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-27 06:55 UTC by Michael Burman
Modified: 2018-06-26 08:39 UTC (History)
2 users (show)

Fixed In Version: ovirt-engine-4.2.4.1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-26 08:39:32 UTC
oVirt Team: Network
rule-engine: ovirt-4.2+
rule-engine: blocker+


Attachments (Terms of Use)
record (3.12 MB, application/x-gzip)
2018-05-27 07:05 UTC, Michael Burman
no flags Details


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 91689 0 master MERGED webadmin: Fix wrong table size in Host Setup Networks popup 2018-05-28 18:33:08 UTC
oVirt gerrit 91698 0 ovirt-engine-4.2 MERGED webadmin: Fix wrong table size in Host Setup Networks popup 2018-05-29 08:20:22 UTC

Description Michael Burman 2018-05-27 06:55:00 UTC
Description of problem:
[UI] - Very low performance when opening the setup networks dialogue, taking few seconds to load the host interfaces and this is visible, the interfaces broken for few seconds.

Attaching record.
I think this regression caused by the fix for the very slow ui we did. 

Version-Release number of selected component (if applicable):
4.2.4-0.1.el7

How reproducible:
100%

Steps to Reproduce:
1. Install/update rhv4.2.4-0.1.el7 and open setup networks

Actual results:
It's very slow and the hots interfaces are broken for few seconds

Expected results:
Should open immediately as used to.

Comment 1 Michael Burman 2018-05-27 07:05:34 UTC
Created attachment 1442206 [details]
record

Comment 2 Red Hat Bugzilla Rules Engine 2018-05-27 08:52:42 UTC
This bug report has Keywords: Regression or TestBlocker.
Since no regressions or test blockers are allowed between releases, it is also being identified as a blocker for this release. Please resolve ASAP.

Comment 3 Ales Musil 2018-05-28 14:17:44 UTC
I did not find it much slower now. I agree that there is little bug with the broken host interfaces. Which should be fixed by the patch.

Comment 4 Michael Burman 2018-06-03 12:58:06 UTC
Verified on - 4.2.4.1-0.1.el7

Comment 5 Sandro Bonazzola 2018-06-26 08:39:32 UTC
This bugzilla is included in oVirt 4.2.4 release, published on June 26th 2018.

Since the problem described in this bug report should be
resolved in oVirt 4.2.4 release, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.