Bug 158294 - e-mail merge does not work.
e-mail merge does not work.
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Caolan McNamara
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-05-20 08:11 EDT by Douglas Furlong
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: 1.9.114-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-07 08:36:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenOffice.org 51638 None None None Never

  None (edit)
Description Douglas Furlong 2005-05-20 08:11:25 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux ppc; en-US; rv:1.7.8) Gecko/20050512 Fedora/1.0.4-2 Firefox/1.0.4

Description of problem:
When using the Mail Merge Wizard, the E-mail message option is grayed out.

There is a comment stating that Open Office was unable to find the Java Mail connection, and points me to Sun's website to find out more.

Version-Release number of selected component (if applicable):
openoffice.org-1.9.100-1, java-1.4.2-gcj-compat-1.4.2.0-40jpp_18rh,  classpathx-mail-1.0-3jpp_1fc

How reproducible:
Always

Steps to Reproduce:
1. Go to Mail Merge Wizard in Open Office
2. Try to select the e-mail mail merge
3.
  

Actual Results:  Option is grayed out, and unselectable

Expected Results:  I should be able to select the e-mail option for mail merge.

Additional info:

Package version

openoffice.org-1.9.100-1, 
java-1.4.2-gcj-compat-1.4.2.0-40jpp_18rh,  
classpathx-mail-1.0-3jpp_1fc

I have tried this on both ppc and i386
Comment 1 Caolan McNamara 2005-06-02 09:56:21 EDT
indeed, interesting. Try editing
.openoffice.org2.0/user/registry/data/org/openoffice/Office/Writer.xcu and
change the "false" under EMailSupported to "true" and restart ooo and see how
much further you get .
Comment 2 Caolan McNamara 2005-06-02 10:40:16 EDT
Ack!, http://user-faq.openoffice.org/servlets/ReadMsg?list=authors&msgNo=7907

We need to implement a mail::XMailService to get mail working
Comment 3 Douglas Furlong 2005-06-02 16:26:15 EDT
Doh.

Does that mean you do not need me to try that fix you've mentioned?

I'm getting the feeling that this feature may be a while coming :\
Comment 4 Caolan McNamara 2005-07-05 09:34:25 EDT
Might not be too long, I've started and implementation, and it doesn't look
*too* hard. http://blogs.linux.ie/caolan/2005/07/05/email-mailmerge/
Comment 5 Caolan McNamara 2005-07-06 08:26:35 EDT
Submitted implementation upstream as
http://www.openoffice.org/issues/show_bug.cgi?id=51638
I'll build it for fedora now and see how it goes.
Comment 6 Caolan McNamara 2005-07-07 08:36:45 EDT
Available in rawhide 1.9.114-2
Comment 7 Douglas Furlong 2005-07-17 05:11:33 EDT
Heyah Caolan.

I've tried the latest build of open office from raw hide, and classpathx-mail
from main, and the option is still grayed out.

Versions...

[root@localhost ~]# rpm -qa | grep openoffice.org
openoffice.org-core-1.9.117-1.2.0.fc5
openoffice.org-math-1.9.117-1.2.0.fc5
openoffice.org-graphicfilter-1.9.117-1.2.0.fc5
openoffice.org-pyuno-1.9.117-1.2.0.fc5
openoffice.org-draw-1.9.117-1.2.0.fc5
openoffice.org-impress-1.9.117-1.2.0.fc5
openoffice.org-writer-1.9.117-1.2.0.fc5
openoffice.org-calc-1.9.117-1.2.0.fc5
openoffice.org-xsltfilter-1.9.117-1.2.0.fc5
[root@localhost ~]# rpm -qa | grep classpathx
classpathx-jaf-1.0-2jpp_3fc
classpathx-mail-1.0-3jpp_1fc


I know that it is not version 114 would that be a problem?
Comment 8 Caolan McNamara 2005-07-17 07:12:59 EDT
you don't need any classpathx stuff, just what you have installed. This is
probably because you ran it in the old OOo which didn't provide it. Try removing
your ~/.openoffice.org* directories and running it again and see if it makes it
become enabled ?
Comment 9 Douglas Furlong 2005-07-17 08:47:48 EDT
Deleting that directory made the difference, it is no longer grayed out.

I don't have time to test this just yet, but will try to some time this week.

Note You need to log in before you can comment on or make changes to this bug.