Bug 1583018 - changelog: Changelog is not capturing rename of files
Summary: changelog: Changelog is not capturing rename of files
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: distribute
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kotresh HR
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1583047 1660225
TreeView+ depends on / blocked
 
Reported: 2018-05-28 05:36 UTC by Kotresh HR
Modified: 2019-10-15 17:57 UTC (History)
2 users (show)

Fixed In Version: glusterfs-5.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1583047 (view as bug list)
Environment:
Last Closed: 2018-10-23 15:10:12 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Kotresh HR 2018-05-28 05:36:10 UTC
Description of problem:
Changelogs are not capturing renames and hence dependant applications like geo-rep and glusterfind are failing.

Version-Release number of selected component (if applicable):
mainline

How reproducible:
Always

Steps to Reproduce:
1. Set distributed gluster volume
2. Enable changelog
3. Mount the volume and do rename of a file
4. Check the backend changelog for the rename record.

Actual results:
Rename is not getting recorded by changelog

Expected results:
Rename should be recorded by changelog.

Additional info:
    The changelog would journal the rename of files only when the DHT sends a special key on the hashed subvol. The key is not being set.

Comment 1 Kotresh HR 2018-05-28 06:56:51 UTC
Volume details:

root@fedora4#gluster vol info
 
Volume Name: master
Type: Replicate
Volume ID: a2eacd30-cd0a-4d20-867e-8c9f465341bd
Status: Started
Snapshot Count: 0
Number of Bricks: 1 x 2 = 2
Transport-type: tcp
Bricks:
Brick1: fedora4:/bricks/brick0/b0
Brick2: fedora4:/bricks/brick0/b1
Options Reconfigured:
performance.client-io-threads: off
nfs.disable: on
transport.address-family: inet
changelog.changelog: on
geo-replication.indexing: on
geo-replication.ignore-pid-check: on

Comment 2 Kotresh HR 2018-05-28 07:03:38 UTC
This is happening only one single dht subvolume. There is a new change in DHT which just does default rename if there is single subvol and this missed the changelog key to be set in xdata.

Comment 3 Worker Ant 2018-05-28 08:40:59 UTC
REVIEW: https://review.gluster.org/20093 (cluster/dht: Fix rename journal in changelog) posted (#1) for review on master by Kotresh HR

Comment 4 Worker Ant 2018-06-25 03:32:34 UTC
COMMIT: https://review.gluster.org/20093 committed in master by "Kotresh HR" <khiremat@redhat.com> with a commit message- cluster/dht: Fix rename journal in changelog

With patch [1], renames are journalled only
on cached subvolume. The dht sends the special
key on the cached subvolume so that the changelog
journals the rename. With single distribute
sub-volume, the key is not being set. This patch
fixes the same.

[1] https://review.gluster.org/10410

fixes: bz#1583018
Change-Id: Ic2e35b40535916fa506a714f257ba325e22d0961
Signed-off-by: Kotresh HR <khiremat@redhat.com>

Comment 5 Shyamsundar 2018-10-23 15:10:12 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-5.0, please open a new bug report.

glusterfs-5.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://lists.gluster.org/pipermail/announce/2018-October/000115.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.