Bug 1583050 - Fails to start guest with Intel vGPU device
Summary: Fails to start guest with Intel vGPU device
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm-rhev
Version: 7.6
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Alex Williamson
QA Contact: Guo, Zhiyi
URL:
Whiteboard:
Depends On:
Blocks: 1590511
TreeView+ depends on / blocked
 
Reported: 2018-05-28 07:36 UTC by Fangge Jin
Modified: 2018-11-08 08:27 UTC (History)
15 users (show)

Fixed In Version: qemu-kvm-rhev-2.12.0-7.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1590511 (view as bug list)
Environment:
Last Closed: 2018-11-01 11:09:52 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Fangge Jin 2018-05-28 07:36:53 UTC
Description of problem:
Fails to start guest with Intel vGPU device

Version-Release number of selected component:
qemu-kvm-rhev-2.12.0-2.el7.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Prepare a guest with Intel vGPU device:
# virsh dumpxml 1|grep hostdev -a3
...
    <hostdev mode='subsystem' type='mdev' managed='no' model='vfio-pci'>
      <source>
        <address uuid='7bb8579b-55ca-4f4d-b70f-498a583c1e6e'/>
      </source>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x03' function='0x0'/>
    </hostdev>
...

2. # virsh start 1
error: Failed to start domain 1
error: internal error: qemu unexpectedly closed the monitor: 2018-05-28T05:31:03.382527Z qemu-kvm: -device vfio-pci,id=hostdev0,sysfsdev=/sys/bus/mdev/devices/7bb8579b-55ca-4f4d-b70f-498a583c1e6e,bus=pci.0,addr=0x3: vfio error: 7bb8579b-55ca-4f4d-b70f-498a583c1e6e: vfio-display-dmabuf: opengl not available


Actual results:
Guest fails to start

Expected results:
Guest starts successfully


Additional info:
qemu-kvm-rhev-2.10.0-21.el7_5.2.x86_64 works well

Comment 2 Alex Williamson 2018-05-29 02:04:36 UTC
QEMU's vfio-pci device defaults to display=auto, so any host kernel where the mdev device exposes a display will now require QEMU to support a display configuration consistent with that display.  This can be avoided adding a display=off parameter to the device, but I think we've broken backwards compatibility by making the default 'auto'.  What host kernel is being used that has GVT-g with display support?

Comment 3 Fangge Jin 2018-05-29 02:37:44 UTC
I tried kernel-3.10.0-862.el7.x86_64 and kernel-3.10.0-894.el7.x86_64, both can reproduce

Comment 4 Alex Williamson 2018-05-29 15:42:28 UTC
Posted a QEMU patch:

http://lists.nongnu.org/archive/html/qemu-devel/2018-05/msg06443.html

I don't see how to resolve this other than turning the display default to "off", posted upstream, we'll see what fallout this causes and how libvirt will handle it if the default changes.  This doesn't seem to be simply a GVT-g bug though, it's a design problem, so re-assigning to me.

Comment 6 Alex Williamson 2018-06-11 21:08:40 UTC
Hi Fangge, would you be able to test that the issue is resolved with this test build?

https://brewweb.engineering.redhat.com/brew/taskinfo?taskID=16678612

Thanks!

Comment 7 Fangge Jin 2018-06-12 03:25:09 UTC
(In reply to Alex Williamson from comment #6)
> Hi Fangge, would you be able to test that the issue is resolved with this
> test build?
> 
> https://brewweb.engineering.redhat.com/brew/taskinfo?taskID=16678612
> 
> Thanks!

I tried with the test build, it works well

Comment 8 Alex Williamson 2018-06-12 14:52:43 UTC
Thanks for testing!

Comment 10 Miroslav Rezanina 2018-07-04 08:33:19 UTC
Fix included in qemu-kvm-rhev-2.12.0-7.el7

Comment 12 Guo, Zhiyi 2018-09-06 08:24:28 UTC
Verify this issue against qemu-kvm-rhev-2.12.0-13.el7.x86_64:

# /usr/libexec/qemu-kvm -device vfio-pci,sysfsdev=/sys/bus/mdev/devices/89d223b5-8e86-4682-b703-acf28f1fece8
VNC server running on ::1:5900

Comment 13 Guo, Zhiyi 2018-09-06 08:25:41 UTC
Mark as verified per comment 12

Comment 14 errata-xmlrpc 2018-11-01 11:09:52 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:3443


Note You need to log in before you can comment on or make changes to this bug.