Bug 1583272 - [SRIOV] NeutronSriovHostConfig missing in SRIOV's env files Edit
Summary: [SRIOV] NeutronSriovHostConfig missing in SRIOV's env files Edit
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 13.0 (Queens)
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: z2
: 13.0 (Queens)
Assignee: Ricardo Noriega
QA Contact: Noam Manos
URL:
Whiteboard: SRIOV
: 1579137 (view as bug list)
Depends On:
Blocks: 1528947
TreeView+ depends on / blocked
 
Reported: 2018-05-28 15:44 UTC by Ricardo Noriega
Modified: 2019-02-11 14:27 UTC (History)
10 users (show)

Fixed In Version: openstack-tripleo-heat-templates-8.0.4-3.el7ost
Doc Type: Enhancement
Doc Text:
Feature: SRIOV with OpenDaylight Reason: One of the TripleO services is missing from the templates. Result: "In order to configure SRIOV properly on the compute nodes, in an OpenDaylight environment, we would need to make sure the following services are present in an environment file: OS::TripleO::Services::ComputeNeutronCorePlugin: ../../docker/services/neutron-plugin-ml2.yaml OS::TripleO::Services::NeutronSriovAgent: ../../docker/services/neutron-sriov-agent.yaml OS::TripleO::Services::NeutronSriovHostConfig: ../../puppet/services/neutron-sriov-host-config.yaml There is an environment file named neutron-opendaylight-sriov.yaml in: /usr/share/openstack-tripleo-heat-templates/environments/services-docker/neutron-opendaylight-sriov.yaml where the user should add the NeutronSriovHostConfig service into the resource registry section. So the environment file would look like: # A Heat environment that can be used to deploy OpenDaylight with SRIOV # This file is to be used with neutron-opendaylight.yaml resource_registry: OS::TripleO::Services::ComputeNeutronCorePlugin: ../../docker/services/neutron-plugin-ml2.yaml OS::TripleO::Services::NeutronSriovAgent: ../../docker/services/neutron-sriov-agent.yaml OS::TripleO::Services::NeutronSriovHostConfig: ../../puppet/services/neutron-sriov-host-config.yaml parameter_defaults: NeutronMechanismDrivers: ['sriovnicswitch','opendaylight_v2'] # Add PciPassthroughFilter to the scheduler default filters #NovaSchedulerDefaultFilters: ['RetryFilter','AvailabilityZoneFilter','RamFilter','ComputeFilter','ComputeCapabilitiesFilter','ImagePropertiesFilter','ServerGroupAntiAffinityFilter','ServerGroupAffinityFilter','PciPassthroughFilter'] #NovaSchedulerAvailableFilters: ["nova.scheduler.filters.all_filters","nova.scheduler.filters.pci_passthrough_filter.PciPassthroughFilter"] #NeutronPhysicalDevMappings: "datacentre:ens20f2" # Number of VFs that needs to be configured for a physical interface #NeutronSriovNumVFs: "ens20f2:5" #NovaPCIPassthrough: # - devname: "ens20f2" # physical_network: "datacentre"
Clone Of:
Environment:
N/A
Last Closed: 2018-08-29 16:36:45 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Launchpad 1773746 None None None 2018-05-28 15:44:39 UTC
OpenStack gerrit 571121 'None' MERGED NeutronSriovHostConfig missing in SRIOV's env files 2020-08-11 18:15:02 UTC
Red Hat Product Errata RHBA-2018:2574 None None None 2018-08-29 16:37:34 UTC

Description Ricardo Noriega 2018-05-28 15:44:40 UTC
This service is missing in both SRIOV files with and without Opendaylight.

The following environment file:

https://github.com/openstack/tripleo-heat-templates/blob/stable/queens/environments/services-docker/neutron-opendaylight-sriov.yaml

Does not contain the NeutronSriovHostConfig as it does:

https://github.com/openstack/tripleo-heat-templates/blob/stable/queens/environments/services-docker/neutron-sriov.yaml

This service is required to perform operations on the host in order to configure SRIOV capable NICs.

Comment 1 Ricardo Noriega 2018-05-30 08:11:08 UTC
The upstream fix is on its way:

https://review.openstack.org/#/q/topic:bug/1773746+(status:open+OR+status:merged)

Comment 2 Mike Kolesnik 2018-05-30 08:24:17 UTC
Ricky, please provide doc text of what needs to be manually done to make it work in GA. The fix will go in z1.

Comment 3 Ricardo Noriega 2018-05-30 13:42:20 UTC
"In order to configure SRIOV properly on the compute nodes, in an OpenDaylight environment, we would need to make sure the following services are present in an environment file:

  OS::TripleO::Services::ComputeNeutronCorePlugin: ../../docker/services/neutron-plugin-ml2.yaml
  OS::TripleO::Services::NeutronSriovAgent: ../../docker/services/neutron-sriov-agent.yaml
  OS::TripleO::Services::NeutronSriovHostConfig: ../../puppet/services/neutron-sriov-host-config.yaml


There is an environment file named neutron-opendaylight-sriov.yaml in:

/usr/share/openstack-tripleo-heat-templates/environments/services-docker/neutron-opendaylight-sriov.yaml

where the user should add the NeutronSriovHostConfig service into the resource registry section. So the environment file would look like:


# A Heat environment that can be used to deploy OpenDaylight with SRIOV
# This file is to be used with neutron-opendaylight.yaml

resource_registry:
  OS::TripleO::Services::ComputeNeutronCorePlugin: ../../docker/services/neutron-plugin-ml2.yaml
  OS::TripleO::Services::NeutronSriovAgent: ../../docker/services/neutron-sriov-agent.yaml
  OS::TripleO::Services::NeutronSriovHostConfig: ../../puppet/services/neutron-sriov-host-config.yaml

parameter_defaults:
  NeutronMechanismDrivers: ['sriovnicswitch','opendaylight_v2']

  # Add PciPassthroughFilter to the scheduler default filters
  #NovaSchedulerDefaultFilters: ['RetryFilter','AvailabilityZoneFilter','RamFilter','ComputeFilter','ComputeCapabilitiesFilter','ImagePropertiesFilter','ServerGroupAntiAffinityFilter','ServerGroupAffinityFilter','PciPassthroughFilter']
  #NovaSchedulerAvailableFilters: ["nova.scheduler.filters.all_filters","nova.scheduler.filters.pci_passthrough_filter.PciPassthroughFilter"]

  #NeutronPhysicalDevMappings: "datacentre:ens20f2"

  # Number of VFs that needs to be configured for a physical interface
  #NeutronSriovNumVFs: "ens20f2:5"

  #NovaPCIPassthrough:
  #  - devname: "ens20f2"
  #    physical_network: "datacentre"

Comment 4 Ricardo Noriega 2018-05-31 07:50:37 UTC
Both patches for master and Queens have landed upstream:

https://review.openstack.org/#/q/topic:bug/1773746+(status:open+OR+status:merged)

Comment 15 Joanne O'Flynn 2018-08-15 08:05:37 UTC
This bug is marked for inclusion in the errata but does not currently contain draft documentation text. To ensure the timely release of this advisory please provide draft documentation text for this bug as soon as possible.

If you do not think this bug requires errata documentation, set the requires_doc_text flag to "-".


To add draft documentation text:

* Select the documentation type from the "Doc Type" drop down field.

* A template will be provided in the "Doc Text" field based on the "Doc Type" value selected. Enter draft text in the "Doc Text" field.

Comment 17 errata-xmlrpc 2018-08-29 16:36:45 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:2574

Comment 20 Christophe Fontaine 2019-02-11 14:27:22 UTC
*** Bug 1579137 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.