Bug 158354 - mod_perl 2.0.1
mod_perl 2.0.1
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: mod_perl (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Joe Orton
David Lawrence
:
Depends On:
Blocks: FC4Update
  Show dependency treegraph
 
Reported: 2005-05-20 16:16 EDT by Jose Pedro Oliveira
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-06-30 05:02:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
mod_perl specfile update (2.02 KB, patch)
2005-05-20 16:16 EDT, Jose Pedro Oliveira
no flags Details | Diff

  None (edit)
Description Jose Pedro Oliveira 2005-05-20 16:16:20 EDT
Description of problem:
mod_perl 2.0.0 is out


Specfile changes:
- Update to 2.0.0.
- Requirement update: httpd >= 2.0.47.
- New requirement: perl >= 3:5.8.6-14 (includes CGI.pm 3.10).
Comment 1 Jose Pedro Oliveira 2005-05-20 16:16:21 EDT
Created attachment 114651 [details]
mod_perl specfile update
Comment 2 Jose Pedro Oliveira 2005-05-20 21:01:17 EDT
Can this be released as a Fedora Core 4 errata?
Comment 3 Warren Togami 2005-05-20 21:37:11 EDT
http://people.redhat.com/wtogami/temp/mod_perl/
Joe Orton built binaries of this and I copied them here for testing.  Please
find people who actually use mod_perl to test this.
Comment 4 Jose Pedro Oliveira 2005-05-20 22:53:44 EDT
The requirements need to be updated:
1) httpd >= 2.0.47   (README and Makefile.PL file)
2) add perl >=  3:5.8.6-14 (for CGI.pm 3.10)

See mod_perl specfile patch in comment #2.
Comment 5 Jose Pedro Oliveira 2005-05-20 22:55:45 EDT
Correction: patch in comment #1.
Comment 6 Ville Skyttä 2005-05-21 03:50:35 EDT
I can help test on Monday.

Anyway, I don't really like the suggested "perl >= 3:5.8.6-14 (for CGI.pm 3.10)"
dependency.  mod_perl does not need _any version_ of CGI.pm nor does it require
Perl >= 5.8.6 as such.  For example, I have a huge mod_perl app at work that,
well, is a real mod_perl app, it does not use CGI.pm for anything.

FC4 users will have a version of Perl installed that will satisfy the above
dependency anyway, so "hardcoding" it will just make life slightly harder for
example for folks who want to rebuild this locally on FC3.

On the other hand, the bump in the versioned httpd dependency looks ok.
Comment 7 Warren Togami 2005-05-21 05:24:21 EDT
I am removing the new perl versioned dependency from -3.
Comment 8 Warren Togami 2005-05-21 05:26:27 EDT
Requires:       httpd-mmn = %([ -a %{_includedir}/httpd/.mmn ] && cat
%{_includedir}/httpd/.mmn || echo missing)

On second thought, isn't this adequate for a httpd dependency?  The mmn number
is supposed to be something about binary compatibilit with modules?
Comment 9 Ville Skyttä 2005-05-21 05:59:50 EDT
AFAICS yep, from httpd changelog:

* Tue Sep 03 2002 Joe Orton <jorton@redhat.com> 2.0.40-6
- provide "httpd-mmn" to manage module ABI compatibility

The versioned httpd build dep is good and should stay, though.
Comment 10 Jose Pedro Oliveira 2005-05-21 11:05:05 EDT
(In reply to comment #6)
> ...
> Anyway, I don't really like the suggested "perl >= 3:5.8.6-14 (for CGI.pm 3.10)"
> dependency.  mod_perl does not need _any version_ of CGI.pm nor does it require
> Perl >= 5.8.6 as such.  For example, I have a huge mod_perl app at work that,
> well, is a real mod_perl app, it does not use CGI.pm for anything.
> 
> FC4 users will have a version of Perl installed that will satisfy the above
> dependency anyway, so "hardcoding" it will just make life slightly harder for
> example for folks who want to rebuild this locally on FC3.
> ...

That's exactly why the perl dependency should be there.  It would require ppl
building mod_perl in FC3 (and RHEL4, ...) to read the mod_perl and perl packages
changelogs before sucessfully installing it in ther distro.  They would be
warned that CGI.pm 3.10 comes _highly_ recommended.
Comment 11 Ville Skyttä 2005-05-21 13:25:12 EDT
Yes, it is always recommended to read the changelogs and docs but no, NOT
required to rebuild or upgrade their Perl because of this.  People who upgrade
from mod_perl 1.99_xx to 2.0.0 (no matter on which distro version) without
reading the docs are most likely in for a few nasty surprises anyway.

Le me repeat, mod_perl does not need CGI.pm _at all_.  An app that uses CGI.pm
and wants to run under mod_perl should set its required versions appropriately,
in its Perl code or rpm deps.  It is not the business of the mod_perl package to
inflict this on everyone.
Comment 13 Warren Togami 2005-05-23 02:29:51 EDT
[mod_perl-devel] Multilib regressions for
/ppc/mod_perl-devel/usr/include/httpd/modperl_xs_sv_convert.h
This means the .h file was identical in the old pacakge between ppc and ppc64,
but now no longer is.

[BAD] [mod_perl] usr/lib/httpd/modules/mod_perl.so lost -DFORTIFY_SOURCE on i386 
Build logs show "-O2 -g -pipe -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -m32
-march=i386 -mtune=pentium4 -fasynchronous-unwind-tables" so there is some other
cause for losing fortify source.  -O0 of perl-DBD-Pg caused this, but this is
some other issue.  Another possible cause is if all static buffers became dynamic.

Both of these issues need to be investigated and fixed before the FC4 update is
issued.
Comment 14 Jose Pedro Oliveira 2005-05-23 14:38:12 EDT
Warren,

Just rebuild mod_perl-2.0.0 in a i386 FC4test3+rawhide system without seeing the
FORTIFY_SOURCE warn/error messages.

RPMS: kernel-2.6.11-1.1340_FC4,  rpm-4.4.1-20,  gcc-4.0.0-8,  perl-5.8.6-15

The only "strange" thing may be using -fpic and -fPIC at the same time. Can
-fpic be safely dropped from the specfile (CFLAGS and OPTIMIZE) ?  
Comment 15 Jose Pedro Oliveira 2005-06-17 20:58:20 EDT
mod_perl 2.0.1 is already available for download in CPAN mirrors.

Announcement:
http://marc.theaimsgroup.com/?l=apache-modperl&m=111904793818463&w=2

CPAN:
http://search.cpan.org/dist/mod_perl/
http://search.cpan.org/~gozer/mod_perl-2.0.1/Changes
Comment 16 Warren Togami 2005-06-18 01:47:01 EDT
/usr/lib/httpd/modules/mod_perl.so lost -DFORTIFY_SOURCE

Rebuilt with 2.0.1, and it still lost FORTIFY_SOURCE.  Should we be concerned
about this?
Comment 17 Warren Togami 2005-06-20 03:31:29 EDT
http://people.redhat.com/wtogami/temp/mod_perl/
Somebody please verify these binaries before pushing to FC4 updates.
Comment 18 Greg Varga 2005-06-27 12:13:07 EDT
Just a quick not that I've made FC3 rpm's from what Warren released. Only line
changed was in the .spec file referrencing FC4 and was just changed to FC3.

I've had no problems with these RPM's, so I'm proposing that they get included
in the FC3 updates as well.

--Greg
Comment 19 Ville Skyttä 2005-06-27 14:31:07 EDT
Pushing this to FC3 would be less trivial than FC4 due to CGI.pm stuff:  
https://www.redhat.com/archives/fedora-perl-devel-list/2005-June/msg00025.html  
Comment 20 Joe Orton 2005-06-27 15:57:39 EDT
Because of the API changes in mod_perl 2.0 it can't be issued as an FC3 update
at all; that would break existing sites horribly.  For FC4 it's fine of course.
Comment 21 Warren Togami 2005-06-29 01:34:12 EDT
Did anybody actually test the binaries in Comment #17?  I will not push it until
somebody gives thumbs up.
Comment 22 Emmanuel Seyman 2005-06-29 04:33:37 EDT
(In reply to comment #21)
>
> Did anybody actually test the binaries in Comment #17?  I will not push it until
> somebody gives thumbs up.

I've installed  the fc4 i386 rpm.
No problems installing and what little I've done with it works fine.
Comment 25 Warren Togami 2005-06-30 05:02:02 EDT
FC4 update issued.

Note You need to log in before you can comment on or make changes to this bug.