Bug 1583565 - [distribute]: Excessive 'dict is null' errors in geo-rep logs
Summary: [distribute]: Excessive 'dict is null' errors in geo-rep logs
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: distribute
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: Mohit Agrawal
QA Contact:
URL:
Whiteboard:
Depends On: 1581553
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-29 09:19 UTC by Mohit Agrawal
Modified: 2018-10-23 15:10 UTC (History)
7 users (show)

Fixed In Version: glusterfs-5.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1581553
Environment:
Last Closed: 2018-10-23 15:10:12 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Comment 1 Worker Ant 2018-05-29 09:31:27 UTC
REVIEW: https://review.gluster.org/20096 (dht: Excessive 'dict is null' logs in dht_revalide_cbk) posted (#1) for review on master by MOHIT AGRAWAL

Comment 2 Worker Ant 2018-05-29 17:14:13 UTC
COMMIT: https://review.gluster.org/20096 committed in master by "MOHIT AGRAWAL" <moagrawa@redhat.com> with a commit message- dht: Excessive 'dict is null' logs in dht_revalidate_cbk

Problem: In case of error(ESTALE/ENOENT) dht_revalidate_cbk
         throws "dict is null" error because xattr is not available

Solution: To avoid the logs update condition in dht_revalidate_cbk
          and dht_lookup_dir_cbk

BUG: 1583565
Change-Id: Ife6b3eeb6d91bf24403ed3100e237bb5d15b4357
fixes: bz#1583565
Signed-off-by: Mohit Agrawal <moagrawa@redhat.com>

Comment 3 Shyamsundar 2018-10-23 15:10:12 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-5.0, please open a new bug report.

glusterfs-5.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://lists.gluster.org/pipermail/announce/2018-October/000115.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.