Bug 1583591 - Podman should be installed in all nodes using cri-o
Summary: Podman should be installed in all nodes using cri-o
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Containers
Version: 3.9.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.1.0
Assignee: Mrunal Patel
QA Contact: weiwei jiang
URL:
Whiteboard:
Depends On:
Blocks: 1589013
TreeView+ depends on / blocked
 
Reported: 2018-05-29 10:16 UTC by Eduardo Minguez
Modified: 2019-06-04 10:40 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Feature: Add podman to rhcos. Reason: Help debugging and troubleshooting. Result: Added.
Clone Of:
Environment:
Last Closed: 2019-06-04 10:40:21 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:40:28 UTC

Description Eduardo Minguez 2018-05-29 10:16:15 UTC
Description of problem:
Current openshift-ansible installer doesn't install podman by default, so debugging issues is complicated.

Version-Release number of the following components:
[cloud-user@crio-bastion ~]$ rpm -q openshift-ansible
openshift-ansible-3.9.27-1.git.0.52e35b5.el7.noarch
[cloud-user@crio-bastion ~]$ rpm -q ansible
ansible-2.4.4.0-1.el7ae.noarch
[cloud-user@crio-bastion ~]$ ansible --version
ansible 2.4.4.0
  config file = /home/cloud-user/ansible.cfg
  configured module search path = [u'/home/cloud-user/.ansible/plugins/modules', u'/usr/share/ansible/plugins/modules']
  ansible python module location = /usr/lib/python2.7/site-packages/ansible
  executable location = /usr/bin/ansible
  python version = 2.7.5 (default, Feb 20 2018, 09:19:12) [GCC 4.8.5 20150623 (Red Hat 4.8.5-28)]

How reproducible:
Install OCP using cri-o
openshift_use_crio=true
openshift_crio_use_rpm=true
openshift_crio_enable_docker_gc=true

Steps to Reproduce:
1. Install ocp using cri-o
2. Try to debug issues
3.

Actual results:
podman not installed by default

Expected results:
podman installed by default

Additional info:

Comment 1 Eduardo Minguez 2018-05-29 10:42:33 UTC
Also cri-tools should be installed.

Comment 2 Scott Dodson 2018-05-29 15:27:53 UTC
Antonio was already looking at adding this for 3.10.

Comment 3 Scott Dodson 2018-05-29 15:28:48 UTC
Sorry, meant to provide more info before sending this over. It looks like cri-tools shipped in OCP 3.9 and newer channels. And podman is in RHEL 7.5 channels so both packages should be readily available.

Comment 4 Antonio Murdaca 2018-05-29 15:29:54 UTC
we don't have full podman integration with CRI-O right now right? crictl should be enough for debugging afaict. Dan wdyt?

Comment 5 Antonio Murdaca 2018-06-05 13:49:15 UTC
Mrunal, agree this is not a 3.10 blocker?

Comment 6 Mrunal Patel 2018-06-05 14:31:29 UTC
podman's libpod isn't yet integrated with CRI-O so it isn't ready for debugging CRI-O yet. It can be used to manage images but not the runtime side. It shouldn't be a blocker for 3.10.

Comment 12 weiwei jiang 2019-03-08 07:22:17 UTC
Verified according to https://bugzilla.redhat.com/show_bug.cgi?id=1583591#c11

Comment 16 errata-xmlrpc 2019-06-04 10:40:21 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.