Bug 1583637 - HE Wizard - General error message displayed with no field-specific errors
Summary: HE Wizard - General error message displayed with no field-specific errors
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: cockpit-ovirt
Classification: oVirt
Component: Hosted Engine
Version: 0.11.25
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: ovirt-4.2.4
: ---
Assignee: Phillip Bailey
QA Contact: Yihui Zhao
URL:
Whiteboard:
: 1583290 (view as bug list)
Depends On:
Blocks: cockpit-ovirt-0.11.28
TreeView+ depends on / blocked
 
Reported: 2018-05-29 12:03 UTC by Phillip Bailey
Modified: 2018-06-26 08:36 UTC (History)
11 users (show)

Fixed In Version: cockpit-ovirt-0.11.26
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-26 08:36:32 UTC
oVirt Team: Integration
rule-engine: ovirt-4.2+
rule-engine: blocker+
cshao: testing_ack+


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 91717 0 ovirt-4.2 MERGED wizard: Fix VM IP validation issue 2018-05-30 14:20:14 UTC
oVirt gerrit 91804 0 ovirt-4.2 MERGED wizard: Fix VM IP validation issue 2018-05-30 14:20:28 UTC

Description Phillip Bailey 2018-05-29 12:03:59 UTC
Description of problem:
When deploying HE using DHCP via the Cockpit wizard, the general error message "Please correct errors before moving to the next step." is displayed when the user clicks "Next" in the first step, but no errors are shown at the field level.

The issue is that the VM IP CIDR prefix is being validated even when DHCP is being used. Since the field is hidden, the error message is, as well.

Version-Release number of selected component (if applicable):
cockpit-ovirt-dashboard-0.11.25-1

How reproducible:
100%

Steps to Reproduce:
1. Attempt to deploy HE via the Cockpit wizard using DHCP
2. Click "Next" while on the VM step

Actual results:
"Please correct errors before moving to the next step." will be displayed at the top of the page, but no field-specific error message will be shown.

Expected results:
The wizard moves to the next step or displayed field-specific error messages.


Additional info:

Comment 1 Ryan Barry 2018-05-29 12:52:16 UTC
*** Bug 1583290 has been marked as a duplicate of this bug. ***

Comment 2 cshao 2018-05-30 05:36:40 UTC
provide qa_ack+ flag and regression & testblocker keyword according bug 1583290.

Comment 3 Yihui Zhao 2018-06-01 07:17:09 UTC
Tested with cockpit-ovirt-0.11.27, it works well for me.

So, change the bug's status to verified.

Comment 4 Sandro Bonazzola 2018-06-26 08:36:32 UTC
This bugzilla is included in oVirt 4.2.4 release, published on June 26th 2018.

Since the problem described in this bug report should be
resolved in oVirt 4.2.4 release, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.