Note: This bug is displayed in read-only format because the product is no longer active in Red Hat Bugzilla.
RHEL Engineering is moving the tracking of its product development work on RHEL 6 through RHEL 9 to Red Hat Jira (issues.redhat.com). If you're a Red Hat customer, please continue to file support cases via the Red Hat customer portal. If you're not, please head to the "RHEL project" in Red Hat Jira and file new tickets here. Individual Bugzilla bugs in the statuses "NEW", "ASSIGNED", and "POST" are being migrated throughout September 2023. Bugs of Red Hat partners with an assigned Engineering Partner Manager (EPM) are migrated in late September as per pre-agreed dates. Bugs against components "kernel", "kernel-rt", and "kpatch" are only migrated if still in "NEW" or "ASSIGNED". If you cannot log in to RH Jira, please consult article #7032570. That failing, please send an e-mail to the RH Jira admins at rh-issues@redhat.com to troubleshoot your issue as a user management inquiry. The email creates a ServiceNow ticket with Red Hat. Individual Bugzilla bugs that are migrated will be moved to status "CLOSED", resolution "MIGRATED", and set with "MigratedToJIRA" in "Keywords". The link to the successor Jira issue will be found under "Links", have a little "two-footprint" icon next to it, and direct you to the "RHEL project" in Red Hat Jira (issue links are of type "https://issues.redhat.com/browse/RHEL-XXXX", where "X" is a digit). This same link will be available in a blue banner at the top of the page informing you that that bug has been migrated.

Bug 1583763

Summary: lsmcli volume-replicate-range arguments should be limited to volume size
Product: Red Hat Enterprise Linux 7 Reporter: Jakub Krysl <jkrysl>
Component: libstoragemgmtAssignee: Tony Asleson <tasleson>
Status: CLOSED ERRATA QA Contact: Jakub Krysl <jkrysl>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 7.5CC: tasleson
Target Milestone: rc   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2019-08-06 12:40:24 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:

Description Jakub Krysl 2018-05-29 15:42:54 UTC
Description of problem:
'lsmcli volume-replicate-range' arguments --count, --src-start and --dst-start have no limit to the size of them, so it is possible for example to replicate many more blocks than there are on the volume itself. I tested only with sim target as I was not sure if it is safe to test this on real one.

Version-Release number of selected component (if applicable):
libstoragemgmt-1.6.2-1

How reproducible:
100%

Steps to Reproduce:
1. lsmcli -u "sim://" volume-create --name vol1 --size 10M --pool POOL_ID_00001
2. lsmcli -u "sim://" volume-create --name vol2 --size 10M --pool POOL_ID_00001
3. lsmcli -u "sim://" volume-replicate-range --count='100000000000' --src-vol='VOL_ID_00001' --force --dst-vol='VOL_ID_00002' --dst-start='0' --rep-type='CLONE' --src-start='0'

3. lsmcli -u "sim://" volume-replicate-range --count='100' --src-vol='VOL_ID_00001' --force --dst-vol='VOL_ID_00002' --dst-start='100000000000' --rep-type='CLONE' --src-start='0'

3. lsmcli -u "sim://" volume-replicate-range --count='100' --src-vol='VOL_ID_00001' --force --dst-vol='VOL_ID_00002' --dst-start='0' --rep-type='CLONE' --src-start='100000000000'

Actual results:
commands pass, no errors appear

Expected results:
Probably something along the lines that this would lead to replicating out of the volume...

Additional info:

Comment 4 Jakub Krysl 2019-03-28 11:31:58 UTC
libstoragemgmt-smis-plugin-1.7.3-2.el7.noarch
libstoragemgmt-1.7.3-2.el7.x86_64

# lsmcli -u "sim://" volume-replicate-range --count='100000000000' --src-vol='VOL_ID_00001' --force --dst-vol='VOL_ID_00002' --dst-start='0' --rep-type='CLONE' --src-start='0'
lsmcli: error: --src-start + --count > source size
# lsmcli -u "sim://" volume-replicate-range --count='100' --src-vol='VOL_ID_00001' --force --dst-vol='VOL_ID_00002' --dst-start='100000000000' --rep-type='CLONE' --src-start='0'
lsmcli: error: --dst-start + --count > destination size
# lsmcli -u "sim://" volume-replicate-range --count='100' --src-vol='VOL_ID_00001' --force --dst-vol='VOL_ID_00002' --dst-start='0' --rep-type='CLONE' --src-start='100000000000'
lsmcli: error: --src-start + --count > source size

Comment 6 errata-xmlrpc 2019-08-06 12:40:24 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:2064