Bug 1583764 - [Generic Object] Action with dynamic dialog form does not instantiate Request
Summary: [Generic Object] Action with dynamic dialog form does not instantiate Request
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Automate
Version: 5.9.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: GA
: cfme-future
Assignee: drew uhlmann
QA Contact: Dave Johnson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-29 15:43 UTC by Tsai Li Ming
Modified: 2018-06-04 13:58 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-01 15:58:52 UTC
Category: ---
Cloudforms Team: CFME Core
Target Upstream Version:


Attachments (Terms of Use)

Description Tsai Li Ming 2018-05-29 15:43:20 UTC
Description of problem:

When using a dialog form with dynamic fields, the Action Button of the Generic Object will not Instance the instance, regardless whether the Button Type is Default or Ansible Playbook. 

Such calls will not happen:

Instantiating [/SYSTEM/PROCESS/Request?GenericObject%3A%3Ageneric_object=1000000000030&MiqServer%3A%3Amiq_server=1000000000001&User%3A%3Auser=1000000000001&job_template_name=Create%20S3%20Bucket&object_name=Request&request=ansible_tower_job&vmdb_object_type=generic_object]

Instantiating [/SYSTEM/PROCESS/GenericObject?GenericObject%3A%3Ageneric_object=1000000000030&MiqServer%3A%3Amiq_server=1000000000001&User%3A%3Auser=1000000000001&method_name=xxxx&object_name=GenericObject&request=xxxx&vmdb_object_type=generic_object]

When using a static dialog form, it works as expected

Version-Release number of selected component (if applicable):
5.9.2.4.20180501195858_35dc609

How reproducible:
Always

Steps to Reproduce:
1. Create Generic Object
2. Add Default Action Button with a dialog form that includes a dynamic field. 
3. The button shall invoke the /Process/Request/InspectMe, as an example. 

Actual results:
Nothing is called.

Expected results:
The instance shall be created. automation.log should show
Instantiating [/SYSTEM/PROCESS/Request?GenericObject%3A%3Ageneric_object=1000000000030&MiqServer%3A%3Amiq_server=1000000000001&User%3A%3Auser=1000000000001&job_template_name=Create%20S3%20Bucket&object_name=Request&request=ansible_tower_job&vmdb_object_type=generic_object]


Additional info:

Comment 2 Tina Fitzgerald 2018-05-31 13:51:42 UTC
*** Bug 1582873 has been marked as a duplicate of this bug. ***

Comment 3 drew uhlmann 2018-05-31 15:10:23 UTC
It'd be useful to have the dialog attached to this ticket, as well as any automation code running, please.

Comment 4 Tsai Li Ming 2018-06-01 15:55:41 UTC
I can't seem to reproduce this anymore on 5.9.2.4.20180501195858_35dc609. Please feel free to close this. I will reopen if I can reproduce this again.

Comment 5 drew uhlmann 2018-06-01 15:58:52 UTC
Thanks, Tsai!


Note You need to log in before you can comment on or make changes to this bug.