Bug 1583797 - qemu-ga does not have read access to utmp
Summary: qemu-ga does not have read access to utmp
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 27
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Lukas Vrabec
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-29 17:42 UTC by jszep
Modified: 2018-08-08 15:34 UTC (History)
5 users (show)

Fixed In Version: selinux-policy-3.14.2-22.fc29 selinux-policy-3.13.1-284.37.fc27
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-08-08 15:34:40 UTC
Type: ---


Attachments (Terms of Use)

Description jszep 2018-05-29 17:42:17 UTC
User-Agent:       Mozilla/5.0 (X11; Fedora; Linux x86_64; rv:60.0) Gecko/20100101 Firefox/60.0
Build Identifier: 

same as Redhat bugzilla #1571202.    Also is generating huge numbers of error messages...

Reproducible: Always

Actual Results:  
May 29 04:00:45 wildwest audit[697]: AVC avc:  denied  { read } for  pid=697 comm="qemu-ga" name="utmp" dev="tmpfs" ino=12191 scontext=system_u:system_r:virt_qemu_ga_t:s0 tcontext=system_u:object_r:initrc_var_run_t:s0 tclass=file permissive=0
May 29 04:00:48 wildwest setroubleshoot[22037]: SELinux is preventing qemu-ga from read access on the file utmp. For complete SELinux messages run: sealert -l 42c7a22c-86b2-4f2f-85ce-24c246b66afd

Expected Results:  
No messages generated.

This is new behavior since a recent package update.  Looks to be a selinux bug.

Comment 1 Fedora Update System 2018-07-27 09:23:37 UTC
selinux-policy-3.13.1-284.37.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2018-4bb4de2d86

Comment 2 Fedora Update System 2018-07-27 15:39:44 UTC
selinux-policy-3.13.1-284.37.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-4bb4de2d86

Comment 3 Fedora Update System 2018-08-08 15:34:40 UTC
selinux-policy-3.13.1-284.37.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.