Bug 1583800 - python-pyroute2 FTBFS on python 3.7
Summary: python-pyroute2 FTBFS on python 3.7
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: python-pyroute2 (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: Unspecified Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Peter V. Saveliev
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: PYTHON37
TreeView+ depends on / blocked
 
Reported: 2018-05-29 17:53 UTC by Miro Hrončok
Modified: 2018-06-19 07:46 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-06-19 07:46:06 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
build.log from copr (98.28 KB, text/plain)
2018-05-29 17:53 UTC, Miro Hrončok
no flags Details
root.log from copr (29.47 KB, text/plain)
2018-05-29 17:54 UTC, Miro Hrončok
no flags Details
Rebased upstream commit (11.55 KB, patch)
2018-05-29 21:46 UTC, Miro Hrončok
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Github svinota pyroute2 issues 467 None None None 2018-05-29 17:58 UTC

Description Miro Hrončok 2018-05-29 17:53:00 UTC
Created attachment 1445479 [details]
build.log from copr

Description of problem: python-pyroute2 FTBFS on python 3.7, it uses async (now keyword) as variable name.

+ /usr/lib/rpm/brp-python-bytecompile /usr/bin/python 1
Bytecompiling .py files below /builddir/build/BUILDROOT/python-pyroute2-0.4.21-2.fc29.x86_64/usr/lib/python3.7 using /usr/bin/python3.7
*** Error compiling '/builddir/build/BUILDROOT/python-pyroute2-0.4.21-2.fc29.x86_64/usr/lib/python3.7/site-packages/pyroute2/devlink.py'...
  File "/usr/lib/python3.7/devlink.py", line 20
    async = kwarg['async']
          ^
SyntaxError: invalid syntax
*** Error compiling '/builddir/build/BUILDROOT/python-pyroute2-0.4.21-2.fc29.x86_64/usr/lib/python3.7/site-packages/pyroute2/ipdb/main.py'...
  File "/usr/lib/python3.7/main.py", line 861
    self.mnl.bind(groups=self.nl_bind_groups, async=self._nl_async)
                                                  ^
SyntaxError: invalid syntax
*** Error compiling '/builddir/build/BUILDROOT/python-pyroute2-0.4.21-2.fc29.x86_64/usr/lib/python3.7/site-packages/pyroute2/iwutil.py'...
  File "/usr/lib/python3.7/iwutil.py", line 156
    async = kwarg['async']
          ^
SyntaxError: invalid syntax
*** Error compiling '/builddir/build/BUILDROOT/python-pyroute2-0.4.21-2.fc29.x86_64/usr/lib/python3.7/site-packages/pyroute2/netlink/devlink/__init__.py'...
  File "/usr/lib/python3.7/__init__.py", line 129
    def bind(self, groups=0, async=False):
                                 ^
SyntaxError: invalid syntax
*** Error compiling '/builddir/build/BUILDROOT/python-pyroute2-0.4.21-2.fc29.x86_64/usr/lib/python3.7/site-packages/pyroute2/netlink/event/__init__.py'...
  File "/usr/lib/python3.7/__init__.py", line 21
    def bind(self, groups=0, async=False):
                                 ^
SyntaxError: invalid syntax
*** Error compiling '/builddir/build/BUILDROOT/python-pyroute2-0.4.21-2.fc29.x86_64/usr/lib/python3.7/site-packages/pyroute2/netlink/generic/__init__.py'...
  File "/usr/lib/python3.7/__init__.py", line 29
    def bind(self, proto, msg_class, groups=0, pid=None, async=False):
                                                             ^
SyntaxError: invalid syntax
*** Error compiling '/builddir/build/BUILDROOT/python-pyroute2-0.4.21-2.fc29.x86_64/usr/lib/python3.7/site-packages/pyroute2/netlink/nl80211/__init__.py'...
  File "/usr/lib/python3.7/__init__.py", line 641
    def bind(self, groups=0, async=False):
                                 ^
SyntaxError: invalid syntax
*** Error compiling '/builddir/build/BUILDROOT/python-pyroute2-0.4.21-2.fc29.x86_64/usr/lib/python3.7/site-packages/pyroute2/netlink/nlsocket.py'...
  File "/usr/lib/python3.7/nlsocket.py", line 906
    def bind(self, groups=0, pid=None, async=False):
                                           ^
SyntaxError: invalid syntax
*** Error compiling '/builddir/build/BUILDROOT/python-pyroute2-0.4.21-2.fc29.x86_64/usr/lib/python3.7/site-packages/pyroute2/netlink/rtnl/iprsocket.py'...
  File "/usr/lib/python3.7/iprsocket.py", line 49
    def bind(self, groups=rtnl.RTNL_GROUPS, async=False):
                                                ^
SyntaxError: invalid syntax
*** Error compiling '/builddir/build/BUILDROOT/python-pyroute2-0.4.21-2.fc29.x86_64/usr/lib/python3.7/site-packages/pyroute2/netlink/rtnl/riprsocket.py'...
  File "/usr/lib/python3.7/riprsocket.py", line 13
    def bind(self, groups=rtnl.RTNL_GROUPS, async=False):
                                                ^
SyntaxError: invalid syntax


Version-Release number of selected component (if applicable): 0.4.21-2.fc29

Logs attached.

This is blocking mock.

Comment 1 Miro Hrončok 2018-05-29 17:54 UTC
Created attachment 1445481 [details]
root.log from copr

Comment 3 Miro Hrončok 2018-05-29 17:58:15 UTC
This is **not** yet fixed upstream.

Comment 4 Peter V. Saveliev 2018-05-29 20:46:36 UTC
Fixed in the master branch, not in a release.

The next release planned ~10.06. If needed earlier, ping me pls.

Comment 5 Miro Hrončok 2018-05-29 21:46 UTC
Created attachment 1445567 [details]
Rebased upstream commit

With rebased https://github.com/svinota/pyroute2/commit/6153d375ff4b3770f84f0afca8ee0a1b8ea54604 (attached) python-pyroute2 builds on Python 3.7.

Since it has no %check, we don't know if it works, but it at least builds.

Comment 6 Miro Hrončok 2018-06-11 08:40:22 UTC
Peter, how's the release and Fedora bump?

Comment 7 Peter V. Saveliev 2018-06-12 09:36:56 UTC
The release of 0.5.2 is planned on Sunday 17.06.

I also make the rpm package on Sunday.

Comment 8 Miro Hrončok 2018-06-19 07:46:06 UTC
Patched.


Note You need to log in before you can comment on or make changes to this bug.