Bug 1583825 - [RFE] mass-deployable/homogenized display configuration
Summary: [RFE] mass-deployable/homogenized display configuration
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: mutter
Version: 7.5
Hardware: All
OS: Linux
high
high
Target Milestone: rc
: ---
Assignee: Jonas Ådahl
QA Contact: Desktop QE
Marie Dolezelova
URL:
Whiteboard:
Depends On:
Blocks: 1656436 1636561
TreeView+ depends on / blocked
 
Reported: 2018-05-29 19:21 UTC by Joe Wright
Modified: 2019-08-12 11:18 UTC (History)
14 users (show)

Fixed In Version: mutter-3.28.3-7.el7
Doc Type: Enhancement
Doc Text:
.*Mutter* now allows for mass-deployable homogenized display configuration The *Mutter* window manager now makes it possible to deploy pre-set display configurations for all users on a system. As a result, *Mutter* no longer requires that the configuration for each user is copied to its own configuration directory, but it can use a system wide configuration file instead. This feature makes *Mutter* suitable for mass deployment of homogenized display configuration. To set the configuration for a single user, create and populate the `~/.config/monitors.xml` file. For the login screen in particular, use the `~/gdm/.config/monitors.xml` file. For system-wide configurations, use the `/etc/xdg/monitors.xml` file.
Clone Of:
: 1636561 (view as bug list)
Environment:
Last Closed: 2019-08-06 12:37:45 UTC
Target Upstream Version:


Attachments (Terms of Use)
Mutter patch for rhel 7.6 (6.94 KB, patch)
2018-10-05 16:56 UTC, Jonas Ådahl
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 3462671 None None None 2018-05-29 19:43:10 UTC
Red Hat Product Errata RHBA-2019:2044 None None None 2019-08-06 12:38:19 UTC

Description Joe Wright 2018-05-29 19:21:42 UTC
Description of problem:
- As things currently stand, mutter and/or ~/.config/monitors.xml overrides xorg/xorg.conf, and cannot use a generic configuration. It flatly requires that the configuration be defined using display serial numbers (in current versions, including in Fedora 28). This creates a major problem for mass deployment where it is not feasible to know display serial numbers. Additionally, the configuration used to be read from /etc/gnome-settings-daemon/monitors.xml but that seems to have been dropped. This change would need to be reverted in addition to a method to allow "generic" non-serialized display configurations for the purpose of mass-deployment/automation/homogenization

 
How would the customer like to achieve this? (List the functional requirements here)  
- A generic display configuration can be passed via kickstart post-install script/ansible/some other deployment automation solution that sets the default display configuration

  
Is there already an existing RFE upstream or in Red Hat Bugzilla?  
- No
  
Does the customer have any specific timeline dependencies and which release would they like to target (i.e. RHEL5, RHEL6)?  
- As soon as possible
  
Is the sales team involved in this request and do they have any additional input?  
- No

List any affected packages or components.  
- mutter
- gnome-settings-daemon
- control-center


Would the customer be able to assist in testing this functionality if implemented?
- Yes

Comment 5 Derek Schrock 2018-06-01 21:54:00 UTC
Duplicate of bug 1581806

Comment 7 Jonas Ådahl 2018-10-05 16:56:50 UTC
Created attachment 1490893 [details]
Mutter patch for rhel 7.6

Comment 21 errata-xmlrpc 2019-08-06 12:37:45 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:2044


Note You need to log in before you can comment on or make changes to this bug.